Troubleshooting
Problem
Events with same ScopeID, within configured grouping Time Window, are not grouped together by CNEA.
Symptom
The CNEA services will fail to process more than one event with a double colon.
The Aggregation Collator service will give a message for the first events, saying "Unable to process dedup member (json exception)"
The Aggregation Collator service will give a message for the first events, saying "Unable to process dedup member (json exception)"
Cause
Double colon has special meaning for the dedup pod and is used as a field separator.
Environment
Steps to reproduce the behavior:
- Set the logs for the Aggregation Collator Service to TRACE by updating the LOG_LEVEL in its deployment
- Update two Object Server events to set FirstOccurrence = getdate() and ScopeID = "FX::Blank Site"
- The events will not be grouped - their CEACorrelationKey will not be updated.
- The Log file for the Aggregation Collator will show the error above.
Diagnosing The Problem
Check for "Unable to process dedup member (json exception)" in the logs for the aggregation collator pod.
Resolving The Problem
To resolve the issue, ensure populated ScopeID fields do not contain double colons. Navigate to Insights->Scope Based Grouping to see the policies for setting ScopeID See here for more details
Release 1.6.10 of Event Manager will contain a code fix for this issue.
Document Location
Worldwide
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Document Information
Modified date:
04 September 2023
UID
ibm17004983