IBM Support

CWWKS1100A : Authentication did not succeed for user ID. An invalid user ID or password was specified

Troubleshooting


Problem

CWWKS1100A : Authentication did not succeed for user ID. An invalid user ID or password was specified 
Error can be seen on default-scimsync pod log when User Registry screen information is saved and synchronization server setup starts to load users and groups.

Symptom

Continuous loading under 'Progress' is seen on the User Registry screen while scim-cronjob tries to sync the users and groups as shown in the following screenshot:
image-20230616112605-1
Following errors can also be seen on the default-scimsync pod log:
 
authentication.jaas.modules.UsernameAndPasswordLoginModule A CWWKS1100A: 
Authentication did not succeed for user ID ovYaT8z5xC44NL0K6T5dxtyEOQWQOQWm. An invalid user ID or password was specified.

com.ibm.ws.security.wim.registry.util.LoginBridge            E com.ibm.wsspi.security.wim.exception.WIMSystemException: 
CWIML4520E: The LDAP operation could not be completed. The LDAP naming exception javax.naming.AuthenticationException: 
[LDAP: error code 49 - 80090308: LdapErr: DSID-0C090447, comment: AcceptSecurityContext error, data 52e, v3839�]; 
resolved object com.sun.jndi.ldap.LdapCtx@708cdbba occurred during processing. 

Cause

Error is caused when scim-cronjob bind user is unable to authenticate. The bind user either got deleted or its credentials changed in Active Directory.

Diagnosing The Problem

Look for the bind user in Active Directory and see whether the user exists. If the user exists, then check the username and password and compare them with the values kept in LDAP authentication and User Registry screens.

Resolving The Problem

In order to resolve the error, the bind user needs be corrected, then updated in the LDAP authentication screen and User Registry screen.
Once this user is corrected and User Registry screen is saved, the existing default-scimsync pod is removed and mx4-usersupplied-scim-default-creds-system secret is recreated (mx4 is the example instance name).
Finally, users and groups are synced and the CWWKS1100A error is gone.
image-20230616194023-1

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000F80hAAC","label":"Maximo Application Suite-\u003EMAS Applications-\u003EAdministration"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.9.0;and future releases"}]

Document Information

Modified date:
25 July 2023

UID

ibm17004697