IBM Support

WASをオンラインリポジトリーからインストールしたいが、接続できない

Troubleshooting


Problem

以下のマニュアルを見ながら、IBM Installation Manager を使用してオンラインリポジトリーにアクセスし、WebSphere Application Server (WAS) をインストールしたいのですが、オンラインリポジトリーに接続できません。
WebSphere Application Server オファリングのオンライン製品リポジトリー
https://www.ibm.com/docs/ja/was-nd/9.0.5?topic=installation-online-product-repositories-websphere-application-server-offerings

Symptom

Installation Managerを起動し、「ファイル」-> 「設定」をクリックしたあと、以下のようにリポジトリーにWAS ND V9のURLを入力しました。

URL: https://www.ibm.com/software/repositorymanager/com.ibm.websphere.ND.v90
Repo_1

しかしながら、OK をクリックすると、以下のエラーが表示されて、接続できませんでした。
Repo_2
「はい」をクリックして、リストに追加してみましたが、リポジトリーの接続状態は赤色になっています。
試しに、「接続のテスト」をクリックしても、以下のエラーが出ます。
Repo_3
解決方法を教えてください。

Cause

よくある原因は、Installation Managerのバージョンが古いことです。
Installation Manager V1.8.x もしくは、それ以前のバージョンを使用している場合、オンラインリポジトリーを利用できず、上記のエラーになります。
現在サポートされているWAS V8.5.5およびWAS V9では、Installation Manager V1.9.x の使用を前提としております。
 各レポートにおいて「Prerequisites」 タブをクリックし、 "Installation" の表をご確認ください。WAS V8.5.5およびWAS V9 において、いずれも前提バージョンは V1.9.x以降であることがわかります。

Diagnosing The Problem

まず、現在のInstallation Managerのバージョンをご確認ください。
「ヘルプ」->「IBM Installation Manager について」をクリックします。
Repo_ver1
以下の例では、バージョンが1.8.5であることがわかります。
Repo_ver2

Resolving The Problem

WAS製品を導入する際に使用する IBM Installation Manager は、最新バージョンの使用を推奨いたします。
Installation Manager のインストールパッケージ(更新用パッケージを含む) は以下の URL からダウンロード可能です。

Installation Manager and Packaging Utility download documents (英語)
https://www.ibm.com/support/pages/node/609575
 
導入バージョンの"Download document"をクリックし、ご入手ください。
なお、参考ですが、上記のリンク文書の一番下に、以下のような太字の注意事項が記載されており、
"all pre-1.9 releases" つまり、1.8.xのような、1.9より前のバージョンをご使用されているユーザー様は、最新リリースへ更新ください と記載されております。
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Versions 1.8.9.6 and prior are superseded by 1.9.x releases. Users of all pre-1.9 releases should upgrade their systems to the most recent release above.
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Installation Manager のバージョンを更新する手順は、以下のリンクを参照ください。3種類の方法が用意されております。
Installation Manager のインストールまたは更新
https://www.ibm.com/docs/ja/installation-manager/1.9.2?topic=manager-installing-updating-installation


 


 
上記でも解決しない場合には、念の為、オンラインリポジトリーが稼働中であるかどうかをご確認ください。

以下のサイトにて、オンラインリポジトリーの状況を公開しております。
Status of IBM Installation Manager Product and Service Repositories (英語)
https://www.ibm.com/support/pages/node/566437
"Content" の箇所の、Repository Status をご参照ください。
稼働中の場合には、online と表示されますが、メンテナンス中もしくは障害発生中の場合、offline と表示され、状況が更新されます。offline の場合には、オンラインリポジトリーに接続できません。その場合には、しばらくお待ちいただき、online と表示されてから再度お試しください。

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB67","label":"IT Automation \u0026 App Modernization"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"ARM Category":[{"code":"a8m50000000CdToAAK","label":"WebSphere Application Server traditional-All Platforms-\u003EInstall Update and Migration-\u003EWAS traditional-\u003EInstall Documentation"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
02 February 2024

UID

ibm17004173