IBM Support

FNCM: Retrieve IAM Access Token task fails in Content Operator when deploying Automation Document Processing

Troubleshooting


Problem

When you deploy Cloud Pak for Business Automation to include Automation Document Processing, the Content Operator task FNCM: Retrieve IAM Access Token fails with the error:
Failed to get access token, invalid token request parameters server_error

Cause

An incorrect user or password is being used to request the access token.

Resolving The Problem

Correct the ibm-adp-secret properties.
  1. envOwnerUser must be the full DN string.
  2. If authentication uses an email address or some other alternate value, add envOwnerUsername to the secret and set it to the email address or alternate value.
  3. Confirm that envOwnerPassword is correct for envOwnerUsername.  If envOwnerUsername is not used, confirm it is correct for envOwnerUser.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBYVB","label":"IBM Cloud Pak for Business Automation"},"ARM Category":[{"code":"a8m3p000000hAKPAA2","label":"Operate-\u003EADP Install\\Upgrade\\Setup"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
12 June 2023

UID

ibm17002775