Troubleshooting
Problem
After customizing an existing module, you can test the changes by configuring Order Hub to connect to your toolkit environment as documented here.
However, on clicking on the menu item that you have enabled for customization, a blank screen is shown.
Symptom
On clicking on the menu item that you have enabled for customization, a blank loading screen is shown instead of rendering the UI from your local server.
Cause
There can be multiple reasons for this issue. However, the most common causes are -
1. Order Hub has been installed in DTK with ORDERHUB_MODE=oms set in om-compose.properties.
2. The command used to extract the source code to your local workstation has version set to oms.
3. You are using an older version of DTK.
4. Temporary certificate of bucgenerichost is not accepted on the browser.
Diagnosing The Problem
Enabling network logs will give a clear understanding of the root cause.
- Verify the network calls are made to bucgenerichost(expected) or localhost.
Check the extracted orderhub-code\<module>\overrides.json file
- Verify the hostname attribute to see it is set to bucgenerichost(expected) or localhost.
Resolving The Problem
Ensure the following options are set while performing customization:
1. Order Hub has been installed in DTK with ORDERHUB_MODE=omoc set in om-compose.properties.
2. The command used to extract the source code to your local workstation has version set to omoc.
3. You are using the latest version of DTK.
4. Since this angular HTTPS server does not have a valid certificate, on every server start (yarn start), you cannot immediately view the application in Order Hub. You need to accept a temporary certificate.
- This can be done by accessing the following URL as a different tab in the same browser window used to access Order Hub- https://bucgenerichost:<port>/<base_href>.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cy05AAA","label":"OrderHub"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"SaaS"}]
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Document Information
Modified date:
30 June 2023
UID
ibm16999937