IBM Support

Same user shows twice in TM1 Database

Question & Answer


Question

The same user shows twice in TM1 Database. One shows with regular name and second shows with regular name + CAM ID. Why this happens? How to fix that?

Cause

The user names presented there are the default display name, an alias of the actual CAM ID. A part of the CAM ID is a unique ID determined by AD. Therefore, recreation and some other actions can alter that AD-ID, a new CAMID is created and then upon first login imported to TM1. Once such a new CAM-ID is created, the friendly name is no longer available as alias (because aliases need to be unique too). Hence the longer names.

Answer

If user CAMID was altered and disjoined from friendly alias name, then upon first login TM1 creates new user that is visible as user name + CAMID. You have to delete both user and ask for login into TM1 again. This creates friendly name associated with the new CAMID. New user is displayed only with friendly (short) name, without any part of CAMID.
You can check full name (with CAMID part) and friendly name associated looking at '}Clients' dimension and turning on/off '}TM1_DefaultDisplayValue' Alias.
}Clients dimension

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m3p000000PC6lAAG","label":"Planning Analytics-\u003EArchitect"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
02 June 2023

UID

ibm16999123