Troubleshooting
Problem
After upgrading to iFix11 can no longer access the the Control Center launch page directly or from the sign-on page.
Symptom
Link does not work
Cause
The fix in iFix11 missed updating some xml files
MFT-14126 (2023-03-05) Description of issue: Required Apache commons-fileupload upgrade to address CVE-2023-24998 - CVSS 7.5 - Potential Denial Of Service.
Description of fix: Upgraded to commons-fileupload-1.5.jar (from commons-fileupload-1.3.3.jar). Security Bulletin: https://www.ibm.com/support/pages/node/6964176
Diagnosing The Problem
jettydefault.log shows an error on a jar not found
java.io.FileNotFoundException: ../ControlCenter/web/ccbase/../../lib/10x_Jars/commons-fileupload-1.3.3.jar (No such file or directory)
ccweb.log shows a 404 error
URI=[/scclaunchpage/] Time=(217 ms) ResponseStatus=[404] ResponseSize=0 Bytes
Resolving The Problem
Apply 6210 iFix11Plus with follow-on fix (2023-03-23)
MFT-14201 - error in jettydefault.log: ... lib/10x_Jars/commons-fileupload-1.3.3.jar (No such file or directory)
(corrected web/ccbase/webapps/sccredirect.xml / scclaunchpage.xml)
MFT-14201 - error in jettydefault.log: ... lib/10x_Jars/commons-fileupload-1.3.3.jar (No such file or directory)
(corrected web/ccbase/webapps/sccredirect.xml / scclaunchpage.xml)
You can also edit the two xml files and replace the name commons-fileupload-1.3.3.jar with commons-fileupload-1.5.jar
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSJC3O","label":"IBM Sterling Control Center Monitor"},"ARM Category":[{"code":"a8m0z000000cwWHAAY","label":"WEB CONSOLE"}],"ARM Case Number":"TS012992886","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.2.1"}]
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Document Information
Modified date:
11 May 2023
UID
ibm16989673