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Failed to invoke a SAML IdP federation with multiple partners that have dupicate ACS

Troubleshooting


Problem

Created a SAML Identity Provider with multiple Service Provider partners.
When 2 or more partner definitions have same Assertion Consumer Service URL entry, IdP initiated SSO or SP initiated SSO is failed.

Symptom

Cause

An Identity Provider definition can have multiple Service Provider partners.
Each partner has individual partner ID. However, some of partners can have same Assertion Consumer Service URL.
When multiple partner definitions have same Assertion Consumer Service URL entry, the Identity Provider sends assertion with incorrect attributes to Assertion Consumer Service URL for Service Provider.

Diagnosing The Problem

On LMI, show each partner definition for the Identity Provider federation definition.
Switch Single Sign-on setting tab and get binding URL
Compare binding URL of each partner to find partners that have same Binding method and URL pair.

Resolving The Problem

Create duplicate Identity Provider federation for each Service Provider partner that has duplicate Assertion Consumer Service URL. For example, myidp and myidp2 Identity Providers.
  • www.myidp.ibm.com/isam/sps/myidp/saml20/
  • www.myidp.ibm.com/isam/sps/myidp2/saml20/
Import partner metadata for each Service Provider into each Identity Provider.
Make sure to import correct Identity Provider metadata on each Service Providers.

Document Location

Worldwide

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Document Information

Modified date:
30 April 2023

UID

ibm16987449