General Page
Table of contents
Issue | Description |
Version
|
---|---|---|
The steps and links for backing up and restoring IBM Cloud Pak foundational services are not available in the IBM Cloud Pak for Business Automation documentation. The IBM Cloud Pak for Business Automation disaster recovery solution requires backing up and restoring both IBM Cloud Pak for Business Automation components and IBM Cloud Pak foundational services. | Symptom: You cannot back up and restore IBM Cloud Pak foundational services by using IBM Documentation. Cause: No further information is available. Solution: For assistance in backing up and restoring IBM Cloud Pak foundational services, contact the IBM Cloud Pak foundational services team. |
23.0.2 |
Issue | Description |
Version
|
---|---|---|
None reported | Symptom: Cause: Solution: |
23.0.2 |
Limitation | Description |
Version
|
---|---|---|
The user cannot use the Test button during the table data annotation in Automation Document Processing (ADP) Designer. | Symptom: In the ADP Designer, the user annotates the table data and clicks the Test button. A blank page is displayed instead of the table (rows and columns) that is based on the new annotations. Cause: A required parameter was missed in the spbackend pod that causes the Test button to not work. Solution: Upgrade to the upcoming fixpack 23.0.2 IF001. |
23.0.2 |
Limitation | Description |
Version
|
---|---|---|
The user must manually install IER plug-in. |
Symptom: When trying to download and load the IER plug-in into IBM Content Navigator, you will be unable to do so.
Solution: You must manually place the plugin in a location visible to IBM Content Navigator by following the steps mentioned in the technote here. |
23.0.2 |
Limitation | Description |
Version
|
---|---|---|
None reported |
Symptom:
Cause: Solution: |
23.0.2 |
Limitation | Description |
Version
|
---|---|---|
Case business objects are not supported as search criteria for related case searches |
Symptom: Even though case business objects are defined in the Case Search view, the case business objects are not listed as search properties for related case searches. |
23.0.2 |
Limitation | Description |
Version
|
---|---|---|
Under certain conditions, when deploying in Starter mode, Operational Decision Manager's dbserver pod might show two pods, instead of just one, and crash. |
Solution:
Force the usage of a block storage class in your custom resource by editing the following value:
|
23.0.2 |
Limitation | Description |
Version
|
---|---|---|
None reported |
Symptom:
Cause: Solution: |
23.0.2 |
Limitation | Description |
Version
|
---|---|---|
No new limitations reported |
Symptom:
Cause: Solution: |
23.0.2 |
Limitation | Description |
Version
|
---|---|---|
None reported
|
Symptom:
Cause: Solution: |
23.0.2 |
Limitation | Description |
Version
|
---|---|---|
Special characters in Keystore password not supported. | Symptom: ICCSAP deployment fails when special characters are specified in secrets file ibm-iccsap-secret. Cause: Special characters are not yet supported in the Keystore password. Solution: Ensure that the keystorePassword in the ibm-iccsap-secret does not contain any special characters until this issue is fixed. This issue will be fixed in a future iFix for the release. |
23.0.2 |
Table of contents
Issue | Description |
Version
|
---|---|---|
The steps and links for backing up and restoring IBM Cloud Pak foundational services are not available in the IBM Cloud Pak for Business Automation documentation. The IBM Cloud Pak for Business Automation disaster recovery solution requires backing up and restoring both IBM Cloud Pak for Business Automation components and IBM Cloud Pak foundational services. | Symptom: You cannot back up and restore IBM Cloud Pak foundational services by using IBM Documentation. Cause: No further information is available. Solution: For assistance in backing up and restoring IBM Cloud Pak foundational services, contact the IBM Cloud Pak foundational services team. |
23.0.1 |
Issue | Description |
Version
|
---|---|---|
The upgrade of foundational services is not supported for 23.0.1 in the following cases:
|
An upcoming release is planned to support an upgrade of a CP4BA deployment that uses a cluster-scoped foundational services instance to a namespace-scoped instance. Remember, you might have a cluster-scoped instance if you originally installed a deployment before CP4BA 21.0.3-IF019, or you installed your CP4BA 22.0.2 deployment from the OCP console without creating a common-service-maps ConfigMap. If you do have this type of deployment, it is recommended that you wait for the new upgrade support. |
23.0.1 |
The documentation Installing Rule Designer shows the wrong version Eclipse. | The documentation shows Eclipse 2020.06. It should show Eclipse 2022.06. | 23.0.1 |
The URL to get product entitlement key is incorrect when running deployment scripts | Symptom:The link will take to IBM Cloud Paks documentation instead of the instructions to generate entitlement key. Cause:The presented URL (https://www.ibm.com/docs/en/cloud-paks/cp-biz-automation/23.0.1/com.ibm.dba.install/op_topics/tsk_images_enterp_entitled.html) is incorrect Solution:Deployment scripts will be updated in the upcoming iFix.Here is the correct URL for instructions to generate product entitlement key. https://www.ibm.com/docs/en/cloud-paks/cp-biz-automation/23.0.1?topic=deployment-getting-access-images-from-public-entitled-registry |
23.0.1 |
Limitation | Description |
Version
|
---|---|---|
The transition from TensorFlow V1 to TensorFlow v2 Object Detection API result in an increase in training time for Data-extraction training . This limitation manifests as a noticeable slowdown in the training process | Symptom: 1. Slower training speed: After the migration from Tensorflow V1 to Tensorflow V2, Users experience a significant increase in training time. 2. Decreased throughput: The training process take longer to converge, resulting in reduced throughput and slower model development. Cause: 1. Changes in the architecture and implementation: TensorFlow v2 introduced significant architectural changes and improvements compared to v1. These changes required modifications in the training pipeline which impacted the overall training time. 2. Optimizations and feature updates: TensorFlow v2 incorporates various optimizations and feature updates that improve the overall performance and functionality of the framework. However, these changes require additional computational resources, leading to increased training time. Solution: Additional computational resources can help in reducing the training time. |
23.0.1 |
Submitting low-quality documents (skewed, rotated, blurry, and so on) might cause the OCR engine 2 runtime pod to exceed the allotted memory allocation and restart. When that occurs, the status of the document that is being processed is marked as ‘Error’. After the pod restarts, the OCR engine 2 runtime pod takes a few minutes or so to initialize. |
Symptom:
1. Documents fail to process, returning a status of Error.
2. The wdu-runtime pod restarts.
Cause:
Repeated memory requests lead to a situation where there is not sufficient memory to process the document. This condition triggers a restart of the wdu-runtime pod. Any document currently processing with the wdu-runtime pod at the time of failure causes the document to fail.
Solution:
Wait for the wdu-runtime pod to return to a running and ready state, then resubmit the documents. Remove low-quality documents that repeatedly cause this problem.
If the failure happens frequently enough, increasing the wdu-runtime pod memory limit alleviates the failure.
|
Cause:
CPFS team is investigating root of issue.
Solution:
- User may instead use the Automatic Provision option
- For more details about regarding 'Provisioning on Demand', see the following topic.
Limitation | Description |
Version
|
---|---|---|
You cannot connect to the IBM Enterprise Records desktop. |
Symptom:
When trying to access the IBM Enterprise Records desktop, an error message says that you cannot connect to the web client. The log also shows that an exception was thrown "java.lang.NoClassDefFoundError: org.apache.xerces.xni.parser.XMLEntityResolver".
Cause: After moving to Java 11, IERApplicationPlugin.jar is unable to resolve the path to XercesImpl.jar in the ICN container. Solution:
|
23.0.1 |
User might be unable to 'Provision on Demand' when using Azure AD |
Symptom:
When trying to 'Provision on Demand' with a newly installed environment, user may get error in Group Membership, reporting Membership Update Status is Skipped, with SkipReason: RedundantExport. Cause: CPFS team is still investigating root of issue. Solution:
|
|
Task Manager is not supported in 23.0.1.x release with Azure AD | Symptom: Task Manager is unable to authorize users when using Azure AD. Cause: Task Manager developer team is still investigating root issue. Solution:
This issue will continue to be investigated, and resolved in future iFixes. |
|
Not able to upload documents larger than 375mb through Administrative Console for Content Platform Engine (ACCE) | Symptom: Not able to upload files larger than 375mb or larger through ACCE. Solution:
Please refer to this topic.
|
Limitation | Description |
Version
|
---|---|---|
None reported |
Symptom:
Cause: Solution: |
23.0.1 |
Limitation | Description |
Version
|
---|---|---|
In a container production runtime environment, the Workplace task list does not refresh automatically after modifying a task. |
Symptom: After you modify a task in Workplace, for example, by changing its date or priority, and save the changes, the task list does not refresh automatically to reflect your changes. Solution: Refresh the task list manually to see the latest changes. |
23.0.1 (fixed in 23.0.2) |
Limitation | Description |
Version
|
---|---|---|
Browsing ruleapps in the RES Console may break with an unexpected 500 error "Client-id is duplicated in the faces tree". | Symptom: Browsing ruleapps in Rule Execution Server console result in broken pages and 500 error pages Solution: User will logout and log back in to restore the Rule Execution Server console. |
23.0.1 |
Limitation | Description |
Version
|
---|---|---|
None reported |
Symptom:
Cause: Solution: |
23.0.1 |
Limitation | Description |
Version
|
---|---|---|
No new limitations reported |
Symptom:
Cause: Solution: |
23.0.1 |
Limitation | Description |
Version
|
---|---|---|
Business Automation Insights is not supported in Automation Decision Services 23.0.1.
|
Automation Decision Services cannot send events to Business Automation Insights.
|
23.0.1 |
Limitation | Description |
Version
|
---|---|---|
Special characters in Keystore password not supported.
|
Symptom: ICCSAP deployment fails when special characters are specified in secrets file ibm-iccsap-secret. Cause: Special characters are not yet supported in the Keystore password. Solution: Ensure that the keystorePassword in the ibm-iccsap-secret does not contain any special characters until this issue is fixed. This issue will be fixed in a future iFix for the release. |
23.0.1 |
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Document Information
Modified date:
28 March 2024
UID
ibm16980739