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After upgrading Cognos with Motio, launching Authoring shows blank page

Troubleshooting


Problem

After upgrading Cognos with Motio, launching Authoring shows blank page
  • Issue is intermittent
  • Issue happens against any report
  • Issue is only shown in report authoring
  • Issue happens against multiple browsers (confirmed against Chrome and Firefox)

Symptom

Browser console debug window:
image-20230320121745-1
Log messages:

[cognosserver.log]

2023-02-23T14:18:03.836+0800 ERROR com.ibm.bi.platform.commons.security.PassportValidator [Default Executor-thread-268] 2q2j9w482Ml8vl2ys9ww49vM994MhjlCh4v2sG89 2q2j9w482Ml8vl2ys9ww49vM994MhjlCh4v2sG89 Msy244lw24dvyvqq8229dq898q2h84jjshlv9jq9 NA checkForPassportValidity: remote passport validation Exception unexpected character '<' at line 1, column 2

2023-02-23T14:18:51.787+0800 ERROR com.ibm.bi.platform.commons.web.BIResponseWrapper [Default Executor-thread-100] d4wyGy2MChG4MjdyhGqwy8sj2qyGj2Cv9vC9G8yj d4wyGy2MChG4MjdyhGqwy8sj2qyGj2Cv9vC9G8yj NA 0.0.0.0 38260 LoginUser-149614924 NA /v1/disp/MotioCI/proxy/ci/actions/broadcastMessageAction/getBroadcastMessages.do bi-service 19679 HttpServletResponseCode for /MotioCI-agent/proxy/ci/actions/broadcastMessageAction/getBroadcastMessages.do is in error: 500

 

[MotioCI-agent.log]

2023-02-23 14:23:55,569 DEBUG [Default Executor-thread-234] [c.f.r.a.p.ProxyServlet]: An exception occurred in doPost [/MotioCI-agent/proxy/ci/actions/broadcastMessageAction/getBroadcastMessages.do]
java.lang.NullPointerException: null
at com.focus.rclci.agent.proxy.ProxyServlet.getCamPassport(ProxyServlet.java:580)
at com.focus.rclci.agent.proxy.ProxyServlet.moveCamPassportToQueryString(ProxyServlet.java:558)
at com.focus.rclci.agent.proxy.ProxyServlet.doPost(ProxyServlet.java:206)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)

Cause

Motio is trying to perform a check against the CAMPassport cookie and does not succeed.

Resolving The Problem

When upgrading Cognos, it's vital that Motio also remains on a compatible version. Check to see whether you might need to upgrade Motio to the latest version.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m500000008d78AAA","label":"Reporting"}],"ARM Case Number":"TS012239417","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.2.4"}]

Document Information

Modified date:
19 March 2023

UID

ibm16964494