Troubleshooting
Problem
QRadar をアップデートする際、yum コマンドの実行中にコマンド・ライン・インターフェース(CLI)でアンキャッチ・エラーが表示されることがあります。
Symptom
パッチテスト中に、以下のエラーでパッチが失敗します:
[INFO](-i-testmode) 164 packages to install
[ERROR](-i-testmode) ERROR: uncaught error running yum command for patch test, please report to QRadar support: Error: timeout
[INFO](-i-testmode) Checking Disk Space...
[INFO](-i-testmode) Disk space checks adequate
[ERROR](-i-testmode) sql pretest errored, halting.[6/9] Install & Upgrade Packages failed to complete successfully.
Errors: [6/9] Install & Upgrade Packages installing produced:
ERROR: uncaught error running yum command for patch test, please report to QRadar support: Error: timeout
Cause
yum コマンドは、アップデートによってインストールされたパッケージの情報を取得しようとしている間にタイムアウトしています。
Resolving The Problem
この問題は、パフォーマンスの問題で yum コマンドがタイムアウトすることが原因です。yum の応答時間を改善するために、いくつかの手順があります。
- リポジトリーが有効になっているものがないことを確認する。
yum repolist
- リストされたリポジトリーを別の場所に移動します。
- yum の設定をバックアップします:
cp /etc/yum.conf /root/yum.conf.backup
- 以下を実行して、yum のプラグイン機能を無効化します。
sed -i -e 's/plugins=1/plugins=0/' /etc/yum.conf
- yum のタイムアウト値を増やします。
grep -i timeout /etc/yum.conf
echo "timeout=120" >> /etc/yum.conf
Related Information
Document Location
Worldwide
[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000cwszAAA","label":"Install"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
Was this topic helpful?
Document Information
Modified date:
31 March 2023
UID
ibm16963262