IBM Support

Insights Service error when using Watson Assistant in IBM Cognos

Troubleshooting


Problem

Error shown when using Watson Assistant:

Sorry, I encountered a problem with our Insights Service.

Please contact your administrator.

 

Symptom

Check your cognosserver.log:
 
[REST call 248] GET http://hostname:9300/bi/v1/select/smarts_feature?assetTypes=module%7CuploadedFile%7Cpackage%7CdataSet2%7Cdata_asset&defType=elasticDismax&qf=featureKey%5E2.0+featureKeyTokenized%5E1.7+featureKeyLemma%5E1.6+searchableConcepts%5E1.0+featureKeyLC%5E1.0&query=data_item&rows=500&tie=0.3 headers={} setCookies={} body='{\"errors\":[{\"code\":\"SEA-GEN-0001\",\"level\":\"error\",\"description\":\"\",\"more_info\":\"\",\"message\":\"Internal error: \\\"Search not Initialized\\\"\"}]}''"}}'
    at com.ibm.smarts.ca.core.rest.client.BIRestCallContext.convertToException(BIRestCallContext.java:387) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.ca.core.rest.client.BIRestCallContext.buildException(BIRestCallContext.java:330) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.ca.core.rest.client.BIRestCallContext.buildResponseObject(BIRestCallContext.java:321) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.ca.core.rest.client.BIRestCallContext.access$300(BIRestCallContext.java:62) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.ca.core.rest.client.BIRestCallContext$1.run(BIRestCallContext.java:174) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.ca.core.rest.client.BIRestCallContext.executeCall(BIRestCallContext.java:198) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.ca.core.rest.client.BIRestCallContext.executeCall(BIRestCallContext.java:140) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.ca.core.rest.client.BIRestCallContext.executeCall(BIRestCallContext.java:136) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.ca.core.rest.client.BIRestCallContext.get(BIRestCallContext.java:204) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.core.rest.client.RestClient.getAsync(RestClient.java:796) ~[ibm-smarts-core-rest-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.core.rest.client.RestClient.getAsync(RestClient.java:789) ~[ibm-smarts-core-rest-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.ca.core.impl.insights.CaInsightsClient.semanticSearchWithNluAsync(CaInsightsClient.java:154) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.ca.core.impl.insights.CaInsightsClient.semanticSearchNlu(CaInsightsClient.java:160) ~[ibm-smarts-smarts-ca-core-11.2.2-2202030457.jar:11.2.2-2202030457]
    at com.ibm.smarts.conversation.rs.provider.ConversationCaProvider.findSemanticResults(ConversationCaProvider.java:644) ~[smarts-conversation.war:?]
    ... 113 more

2023-03-05T21:55:14.025-0800    ERROR    com.ibm.bi.platform.commons.web.BIResponseWrapper    [Default Executor-thread-45878]    jh9884vdMjswsdj9w2CjdhGsjjhh48l9s29CCjGM        jh9884vdMjswsdj9w2CjdhGsjjhh48l9s29CCjGM    NA    0.0.0.0    61105    LoginUser-149614924    NA    /v1/indices/    search    7036    HttpServletResponseCode for /search/v1/indices/ is in error: 503
2023-03-05T21:55:14.025-0800    INFO    startup.Audit.RTUsage.CM    [CM.IndexSynchronization]                NA                                    <parameters><item name="msgText"><![CDATA[The request to http://hostname:9300/bi/v1/indices/ failed: 503 - Service Unavailable. Will retry again in 30 sec.]]></item><item name="msgLocation"><![CDATA[com.cognos.cm.connectors.rest.search.GetIndexSchemaResponseProcessor.processStatusCodes]]></item></parameters>    Success            
2023-03-05T21:55:14.525-0800    INFO    startup.Audit.RTUsage.cms.CM    [Thread-40]    IndexSynchronization_REQ            NA    0.0.0.0    9300        IndexSynchronization_SESS    IndexSynchronization_REQ__    CM    7036        <parameters><item name="msgText"><![CDATA[The request to http://hostname:9300/bi/v1/indices/ failed: 503 - Service Unavailable. Will retry again in 30 sec.]]></item><item name="msgLocation"><![CDATA[com.cognos.cm.connectors.rest.search.GetIndexSchemaResponseProcessor.processStatusCodes]]></item></parameters>    Success           

Cause

The error indicates that the Cognos 'search services' is not starting correctly. The 'insights service', which is used by Watson Assistant, relies on the index and does not work if the 'search services' aren't working. Common causes are usually a corrupted index cache, which can be cause by:
- Cognos crashing abbruptedly
- an 'ungraceful' shutdown (For example, rebooting OS while Cognos was still running)
- potential anti-virus conflicts

Resolving The Problem

Clear your Cognos search indexes. This should not be done on a regular basis or attached to a restart process. This should only be done as a one-time correction for the above symptoms. If you're finding that regular clearing of your search indexes is required, then IBM recommends you engage in our support teams to work out why your indexes are being corrupted.
Steps:
- Stop Cognos
- Kill any orphaned Cognos processes
- Go to [Cognos_install]\data\
- Create a backup for the 'search' folder. Example, rename the 'search' folder to 'search-backup'
- Start Cognos
You should notice the search folder being re-created during started. Also, the startup should indicate that your search indexes are being re-created. Depending on the size of your content, you might need to allow for this process time to complete where it updates in the background automatically.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m500000008d6aAAA","label":"Portal"}],"ARM Case Number":"TS012266671","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.2.4"}]

Document Information

Modified date:
06 March 2023

UID

ibm16960465