IBM Support

License level for user not updating until the user logs in to Cognos.

Question & Answer


Question

When looking at the licenses table used under Manage > Licenses > Global license usage, it shows different license counts than what is assigned to users. This license table will not update until each user logs in.

Cause

The licenses table not updating until the user is authenticated into the Cognos environment is as designed.

Answer

The reason why the licenses are only updated when users log in is because it is based on their accounts and needs to be verified through the authentication process.
If a user with former system administrator privileges does not log in again after their privileges were changed, the license counts will not be updated as the licensing can only be confirmed through the security authentication. This has always been the case with the licensing displayed in the 'Manage > Licenses > Global license usage' area of Cognos.
This behaviour is documented here:
Managing user licenses
https://www.ibm.com/docs/en/cognos-analytics/11.2.0?topic=access-managing-user-licenses
"Note: The usage of each license role is calculated by Cognos Analytics, based on the capabilities of each user when they last logged in."
This document outlines which capabilities count for which licenses:
https://www.ibm.com/support/knowledgecenter/SSEP7J_11.1.0/com.ibm.swg.ba.cognos.ag_manage.doc/c_default_permissions_based_on_licenses.html
Information on how to remove used licenses when a user will no longer be accessing Cognos Analytics can be found in the following technote:
https://www.ibm.com/support/pages/how-remove-used-license-when-user-will-no-longer-be-accessing-cognos-analytics
There is also an existing request for a feature to be added to allow the Administrators to refresh the credentials of the users without having them log in. See the following link:
https://ibm-data-and-ai.ideas.ibm.com/ideas/CA-I-2783

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m3p000000hBKLAA2","label":"Security-\u003EPermissions\/Capabilities"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.1.7;11.2.0;11.2.1;11.2.2;11.2.3;11.2.4"}]

Document Information

Modified date:
09 May 2023

UID

ibm16960247