Troubleshooting
Problem
Old partitions that should be purged exist in Guardium internal database tables. The old partitions can cause performance problems for aggregation processes and patch installation if too many exist.
Symptom
Depending on the Guardium appliance version one or both of these alerts might appear:
- After logging in to Guardium UI, a UI banner warning shows Old partitions found: Oldest partition found: p[date]
- Central Manager Deployment Health Dashboard shows alerts with name - Old partitions found. Alerts are sent from all managed units. The severity of the alert corresponds to the age of oldest partition:
- Older than purge age + 240 days - Critical
- Older than purge age + 120 days - High
- Older than purge age + 62 days - Medium
Cause
There are several possible root causes for having old partitions on the system, for example:
- Days have not been archived or exported and therefore have not been purged
- Invalid timestamps are causing data to not be purged
- There are corrupted partitions that cannot be dropped by the purge process
Resolving The Problem
- Resolve any existing Data not exported or archived: [n] days have not been exported or archived and do not meet the purge criteria UI banner warnings. These warnings appear on units where days have not been exported or archived. For more information, see UI banner warning: Data not exported or archived
- Upgrade to latest bundle patch. Known cases where purge could not clear partitions are resolved in latest bundle patches
- Allow the purge to run once after installing the patch
- If problem remains, resolution can depend on several factors:
- How much data is on the Guardium system
- How many old partitions exist
- The root cause explaining the old partitions
- Whether you have previously attempted to clean up the old partitions
- How many Guardium systems are affected
- Contact Guardium support to begin resolving this issue. Provide the following must gather information
- Support must_gather patch_install_issues
- Support must_gather agg_issues
- Support must_gather system_db_info
- Note: The following document contains an internal section that Guardium support can consult to resolve the problem: IBM Security Guardium v10.0p9998 health check errors - Data older than purge period or Old partitions found.
Document Location
Worldwide
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Document Information
Modified date:
20 April 2023
UID
ibm16958929