IBM Support

AIMgr - Unable to see any Policies under Automation in the AIOps UI

Troubleshooting


Problem

Unable to see any configured policies after navigating to the Automation page in the AIOps UI

Symptom

The aiops-ir-lifecycle-datarouting pod log would have similar errors:
 
{"time":"2023-01-18T06:03:47.274Z","hostname":"aiops-ir-lifecycle-datarouting-","pid":,"level":,"msg":"[Connection] Connection error: connect ETIMEDOUT <IP_ADDRESS>:9093 {\n  broker: 'iaf-system-kafka-bootstrap.cp4waiops.svc:9093',\n  clientId: 'common-datarouting',\n  stack: 'Error: connect ETIMEDOUT <IP_ADDRESS>:9093\\n' +\n    '    at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)'\n}","name":"common-datarouting","tool":"kafka","v":0}

Cause

Kafka crashing consistently, or if Kafka renews its certificate could be a cause for this behavior.
Once Kafka is back up and running, the aiops-ir-lifecycle-datarouting pod does not reset its connection with Kafka.

Resolving The Problem

To resolve the issue:
a) Run the following command:
oc get pod | grep aiops-ir-lifecycle-datarouting | cut -f1 -d" " | xargs oc delete pod

Wait for the aiops-ir-lifecycle-datarouting pod to restart

b) Open a new browser and access the AIOps Page

c) Access the "Automation" and then the "Policies" page and check if all policies are visible
 

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRS1M","label":"IBM Cloud Pak for Watson AIOps"},"ARM Category":[{"code":"a8m3p000000hBd3AAE","label":"Watson AIOps-\u003EAI Manager-\u003EAutomations-\u003EPolicies\/Lifecycle"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
22 February 2023

UID

ibm16957460