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Control Center is getting ACBV001E error when going into Automated Reports

Troubleshooting


Problem

Control Center is getting an ACBV001E error when going into Automated Reports following an upgrade.

Symptom

The web console shows no reports when trying to view them on Report Schedules / Report Schedule details..
No automated reports are running at the scheduled times.

Cause

There were schedules that had no value for visibility in the report schedule definition. This was causing a null pointer error.
Had just upgraded from 6.2.0.0 iFix08 to 6.3.0.0 iFix01.

Diagnosing The Problem

The web logs show the ExceptionControllerAdvice : Error java.lang.NullPointerException
and
HttpEntityMethodProcessor : Writing [ErrorResponse [errors=[ErrorMessage [responseCode=ACBV001E, responseMessage=ACBV001E: Unexpected exc (truncated)...]
before this in the web log the report schedule xml is shown and there is no vistype xml string.

Resolving The Problem

As a quick workaround you can edit the CC_FILES table for the row with FILE_NAME ="Schedule with issue" and add the <vistype>"value"</vistype>in the CONTENT column.
Use the vistype value you are using in other schedules such as public or private.
A fix will be made under MFT-14086 to put in guard code to avoid the NPE.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSJC3O","label":"IBM Sterling Control Center Monitor"},"ARM Category":[{"code":"a8m0z000000cwWHAAY","label":"WEB CONSOLE"}],"ARM Case Number":"TS012130009","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.3.0"}]

Document Information

Modified date:
15 February 2023

UID

ibm16955821