Troubleshooting
Problem
Trying to import a connection profile on ClearQuest Maintenance Tool throws the error mentioned below:
Even if you try to connect to the concerned Oracle database through PDSQL, it throws same error as mentioned below:
pdsql -v ora -db <Oracle database name> -s <Oracle server name> -u ******* -p ******** -co "<connect options>"
EXCEPTION: [Oracle][ODBC][Ora]ORA-12154: TNS:could not resolve the connect identifier specified
[Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr failed
State: 08004 Native: 12154
Connect String used: DRIVER={CCM Oracle Native Client};UID=<Oracle db user>;PWD=******************;DBQ=<Oracle database name>
EXCEPTION: [Oracle][ODBC][Ora]ORA-12154: TNS:could not resolve the connect identifier specified
[Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr failed
State: 08004 Native: 12154
Connect String used: DRIVER={CCM Oracle Native Client};UID=<Oracle db user>;PWD=******************;DBQ=<Oracle database name>
Cause
Oracle client/s are installed and / or the environment variable is set for the Oracle home directory, on the host
Resolving The Problem
Uninstall Oracle client/s installed on the host where the CQ profile is being imported, and make sure all the environment variables ( ex. TNS_ADMIN ) referring to Oracle home directory, are removed.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"ARM Category":[{"code":"a8m0z000000boYlAAI","label":"ClearQuest-\u003EAdministration-\u003EMaintenance Tool"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions"}]
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Document Information
Modified date:
09 February 2023
UID
ibm16953391