Troubleshooting
Problem
The users might see an error when running any Maximo Reports after an upgrade to MAS 8.4.4 or MAS 8.4.5
The user's error looks like the following.
![image-20230131085725-1](/support/pages/system/files/inline-images/image-20230131085725-1.png)
Cause
This error can be caused when a script (or two) is missed in the upgrade process. We saw this error initially in 8.4.4 but also saw it in 8.4.5.
With 8.4.4, it was script HF8440_03.dbc
With 8.4.5, both scripts HF8450_03.dbc and HF8450_05.dbc needed to be run.
Once the HF8450_03.dbc had been run, the first error disappeared and we saw the following error.
"Error occurred in server, check server log for detail"
![image-20230131094907-2](/support/pages/system/files/inline-images/image-20230131094907-2.png)
Resolving The Problem
If you are an IBM MAS-MS customer, contact the SRE team, and request that they run the appropriate scripts and restart the Maximo Pod.
You want to advise your users of an impending restart.
If you are an On Prem user, you can also resolve the issue manually with the following steps.
- Back up the database.
- Run the SQL delete from maxvars where varname='HFMANAGEUPG';
- Run the SQL delete from maxvartype where varname='HFMANAGEUPG';
- Run select * from maxvars where varname='MASIMAGEID" and note the varvalue
- Increment one of digits in the varvalue from step 4 and use it when running update maxvars set varvalue=<modified varvalue> where varname='MASIMAGEID'. These changes allow updatedb to be run again.
- Make sure the SQL is committed to the db
- Rerun updatedb. This will run all of the patch scripts that it didn't run before and re-insert the HFMANAGEUPG with the correct value.
- To check that the issue was resolved, check that select * from maxvars where varname='HFMANAGEUPG' returns HF8450-09
This issue will be fixed in MAS 8.4.6 and 8.5.2.
Document Location
Worldwide
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Historical Number
TPAEREPT;BMXAA4214E;Reports don't run;MASMS
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Document Information
Modified date:
07 February 2023
UID
ibm16891113