IBM Support

QUMEPRVAGT job not ending

Question & Answer


Question

QUMEPRVAGT job not ending, which prevents the system from entering a restricted state.

Cause

Part of the CIMOM server runs under PASE and another part under OS/400 ILE environment.  Ending the CIMOM server via ENDTCP or ENDSBS commands may result in the server ending in the ILE environment but not in PASE.  This prevents the system from entering a restricted state. 

The QUMEPRVAGT job is associated with the *CIMOM TCP/IP server, provided by product 5770UME. It may also referred to as the CIM server.

Answer

The following PTFs to resolve the issue:
V7R3 V7R2
SI68259 SI68294
MF65583 MF65650
The PTFs can be applied immediately.
In addition to the PTFs, the recommendation is to end the *CIMOM server before ending all of TCP/IP or all subsystems:
Use the ENDTCPSVR SERVER(*CIMOM) command to end the *CIMOM server
Allow several minutes for it to end before issuing ENDTCP or ENDSBS SBS(*ALL) commands.

If the issue occurs again after the application of the PTFs, IBM will need the following for further problem determination BEFORE any action (ENDJOBABN/IPL)

Collect...

WRKJOB JOB(QUMEPRVAGT) and note the job number

DSPJOB JOB(NUMBER/QSECOFR/QUMEPRVAGT) OUTPUT(*PRINT)

DSPJOBLOG JOB(NUMBER/QSECOFR/QUMEPRVAGT) OUTPUT(*PRINT)

WRKACTJOB OUTPUT(*PRINT) SBS(QSYSWRK)

Before ending the job abnormally, collect:

STRSST
    Log in
   Select option 1. Start a service tool
   Select option 4. Display/Alter/Dump
   Select option 2. Dump to printer 
   Select option 2. Licensed Internal Code (LIC) data
   Select option 14. Advanced analysis

   Specify:
     Option Command  
        1      PROCESSINFO
   And press <ENTER>
     Options . . . . .   -NAMES <HungJobNumber>
   And press <ENTER>
     Dump title. . . . . . . . . . .   QUMEPRVAGT
   And press <ENTER>
Press F12=Cancel until returned to the System Service Tools (SST) menu
Press F10=Command entry
   WRKJOB and select option 4. Work with spooled files
   Select option 5=Display next to QPCSMPRT
   Look for the value for SIGNALS PROCESS AREA PTR
Press F12=Cancel until returned to the System Service Tools (SST) menu
Repeat steps to get to Advanced analysis
Specify:
     Option Command  
        1      PROCESSINFO
   And press <ENTER>
     Options . . . . .   DSPMEM -L 400 <SIGNALS PROCESS AREA PTR Value>
   And press <ENTER>
     Dump title  . . . . . . . . . . .   DSPMEM
   And press <ENTER>
Press F3=Exit until out of SST


Additional information to be collected:

Collect HUNG job information using QMGTOOLS:

ADDLIBLE LIB(QMGTOOLS)
GO MG

Select option 15. Work Management
Select option 3. Hung job data collection
Specify:
   Output . . . . . . . . . . . . .  *IFS       
   IFS directory to store data  . .   '/tmp/'
   Collect VLOGs  . . . . . . . . .   Y          
   Collect PAL entries  . . . . . .   Y          
   Hung job info:                                
     Job name . . . . . . . . . . .   QUMEPRVAGT 
     Job user . . . . . . . . . . .   QSECOFR    
     Job number . . . . . . . . . .   NNNNNN     
**Where NNNNNN is the hung job number

Press <ENTER>

   If CPF001 is received for procedure HUNGDATA_, ensure the correct job information was specified
   If any inquiry messages are issued thereafter, answer with I for Ignore.

Watch for the message at completion:
     Data saved into file <SystemName>_WMDOCS001.zip in directory /tmp


End the job abnormally:

ENDJOBABN JOB(NNNNNN/QSECOFR/QUMEPRVAGT)
**Where NNNNNN is the hung job number. If that doesn't work, will need to IPL system.
  • SERVICEDOCS:
    To collect SERVICEDOCS, refer to document MustGather: Instructions for User to Collect SERVICEDOCS
     
  • TASKINFO:
    Sign on as a user with at least *JOBCTL authority and access to SST. Do the following:
    1.    Record the job number(s) of the hung job(s).
    2.    On the operating system command line type STRSST, and press the Enter key.
    3.    Select Option 1, Start a service tool, and press the Enter key,
    4.    Select Option 4, Display/Alter/Dump, and press the Enter key,
    5.    Select Option 2. Dump to printer, and press the Enter key,
    6.    Select Option 2, Licensed Internal Code (LIC) data, and press the Enter key,
    7.    Select Option 14, Advanced analysis, and press the Enter key,
    8.    Select TASKINFO from the list, and press the Enter key,
    9.    Type in the Options: -NAMES 123456 -F A
    where 123456 is the job number of the hung job, and press the Enter key,
    10. Dump title. . . . . . . . . . .   TASKINFO
       And press <ENTER>

    Should see 'Dump to printer successfully submitted.' 
    Press F3=Exit until out of SST. You should see 'Dump completed normally'

     
  • End the job abnormally:

    ENDJOBABN JOB(NNNNNN/QSECOFR/QUMEPRVAGT)
    **Where NNNNNN is the hung job number. If that doesn't work, will need to IPL system.

     
  • WRKPTFGRP > press enter > F6 to print 
  • DSPPTF OUTPUT(*PRINT) 
  • CALL PGM(QWTDMPFR)
  • VLOGs AFTER the ENDJOBABDN/IPL completes:
    PRTINTDTA TYPE(*DMP) DMPID(*ALL) PERIOD((*AVAIL DATE))
    Where DATE is 2 days BEFORE the issue.
  • Main storage dump (MSD) if IPL:
    To collect Main Storage Dump (MSD) and VLOGs, refer to document MSD, SYSDump, FSPDump, VLOGs, and PAL Basics

Send the data in:

GO MG
Select option 10. FTP data to IBM 
Specify:
   File type  . . . . . . . . . . .   *IFS
   Case number# (if present)  . . .   TSXXXXXXXXX

Press <ENTER> and page down
   IFS file . . . . . . .    /tmp/<SystemName>_WMDOCS001.zip
Press <ENTER> twice

Or directly issue the command:  
FTP2IBMCMD INPUT(*IFS) CASENBR(TSXXXXXXXXX) IFSFILE('/tmp/<SystemName>_WMDOCS001.zip')
 
Send in the spooled files:

GO MG
Select option 23. FTP spool file to IBM 

**Assuming this is done with the same profile that collected the information
Specify Spool to search as *USER and press <ENTER>
Accept the default of *CURRENT for Spool file username and press <ENTER>
Select option 1=Send to IBM next to the two QPCSMPRT and one QPSRVTRCJ spooled files
Press <ENTER>
Specify the Case number# (if present) as TSxxxxxxxx
Press <ENTER> until the data sends
 

[{"Type":"SW","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000COrAAM","label":"CIMOM Server"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.2.0;7.3.0;7.4.0"}]

Document Information

Modified date:
20 May 2021

UID

nas8N1022311