IBM Support

Uploading CSV to populate OIDC users does not populate when unique identifier is not email.

Troubleshooting


Problem

Attempting to populate users in an OIDC namespace with CSV file can fail if email is not the unique identifier. There won't be an error, but you will not get notice of success. Also, the users in the CSV won't be populated in the OIDC namespace.

Cause

Since, unique identifier is not e-mail we need to add another column in the CSV for proper consumption.
The required column is camIdentity. This needs to be populated with whatever the unique identifier is, such as UPN.

Resolving The Problem

When creating the CSV use camIdentity as one of the columns for the unique identifier.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6OAAS","label":"Security-\u003EAuthentication\/SSO"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.1.7;11.2.4"}]

Document Information

Modified date:
27 January 2023

UID

ibm16858091