IBM Support

Planning Analytics Workspace is unavailable. Try again in a few minutes

Troubleshooting


Problem

The following message is displayed in a web browser when any user is trying to connect to Planning Analytics Workspace:
"Planning Analytics Workspace is unavailable. Try again in a few minutes"
image-20230125184332-2

Symptom

List the container states by using the following command in Powershell:
<PAW_path>/scripts/paw.ps1 ps
In that list:
-All containers are "Up" (except couchdb-init, which ends itself after it initialized couchdb. Let's ignore this one)
-The bss-init container, which initializes bss, is still in "Up" state too, even after several minutes. The bss-init must end before Planning Analytics Workspace can be available.

Cause

The bss container is the one that communicates with the security provider, which corresponds to the PAAuthMode parameter in /config/paw.ps1
This security provider can be set to either "tm1" (TM1 Server native security) or "cam" (Cognos Analytics security).
When bss-init never stops, or when it finally fails and stops after an abnormal amount of time, it indicates an issue with the security provider.

Resolving The Problem

Open <PAW_path>/config/paw.ps1 and take a look at the parameters:
1) In all cases. If "HTTPS" secured protocol appears in some URLs:
If Planning Analytics Workspace is accessing other components (TM1 Admin Server, TM1 Server, TM1 Web, Cognos Analytics) that are configured with custom SSL/TLS, then make sure that all the signer certificates (root CA and intermediate CA certificates) are present in <PAW_path>/config/certs
If TM1 data tier (TM1 Admin Server and TM1 Server) is configured with default SSL, then there is no need to do anything about the "HTTPS" that appears in their URLs (TM1Location and TM1LoginServerURL).
2) If security provider is TM1 Server:
$env:PAAuthMode="tm1"
$env:TM1Location="https://TM1AdminHost:5898"
$env:TM1LoginServerURL="https://TM1ServerMachine:<HTTPPortNumber>"
(In most cases TM1AdminHost and TM1ServerMachine are the same)
In that case:
-Open a web browser on the Windows server machine where Planning Analytics Workspace is installed.
-In that web browser, try to connect to the TM1 Admin Server by using this URL:
    https://TM1AdminHost:5898/api/v1/Servers  
    => Replace TM1AdminHost by your own machine name
    => /api/v1/Servers is case-sensitive
-The web browser would probably warn you about a certificate issue ("Your connection is not private"): ignore the message by clicking "Advanced" link, and then "proceed" or "continue" to the unsafe page.
If you don't receive a JSON response that lists all known TM1 Servers, then verify that "IBM Cognos TM1 Admin Server (x64)" service is correctly started. Be careful if you try to restart it: it would restart all your running TM1 Servers.
-Now in that same web browser, try to connect to the TM1 Server (through REST API) by using this URL:
  https://TM1ServerMachine:<HTTPPortNumber>/api/v1/$metadata
     => Replace TM1ServerMachine by your own machine name
     => HTTPPortNumber is defined in the tm1s.cfg configuration file of the TM1 Server
     => /api/v1/$metadata is case-sensitive
If you don't receive an XML response that lists information on this TM1 Server, then verify that "IBM Cognos TM1 Server - <YourTM1serverName>" service is correctly started. If needed, check for errors in tm1server.log.
If it does not help, then contact IBM Support and log an "IBM Planning Analytics" case.

3) If security provider is Cognos Analytics:

$env:PAAuthMode="cam"
$env:IBMCognosGatewayURL="http://CAgateway:80/ibmcognos/bi/v1/disp"
$env:IBMCognosServlet="http://CAdispatcher:9300/p2pd/servlet/dispatch"
$env:CAMLoginNamespace="CAnamespace"
In that case:
-Open a web browser on the Windows server machine where Planning Analytics Workspace is installed.
-In that web browser, try to connect to Cognos Analytics by using the exact same URL that is defined in IBMCognosGatewayURL parameter.
-If there are several namespaces: select the one defined in CAMLoginNamespace parameter.
If it appears to be an issue with Cognos Analytics, then verify that "IBM Cognos" is correctly started, or try to restart it.
If it does not help, then contact IBM Support and log an "IBM Cognos Analytics" case.

Document Location

Worldwide

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Document Information

Modified date:
25 January 2023

UID

ibm16857667