Troubleshooting
Problem
Changing an Organization name causes all deployed applications to stop functioning.
Symptom
In the app.logs, after an Organization name is changed, receive error:
Exception: The user is not a member of the specified organization Soar43-1
Cause
When the organizational (ORG) name is changed, the apps settings need to be updated as well.
For example, when ORG name is changed from 'Soar43-1' to 'SOAR47':
resutil editorg -orgname "ExistingOrgName" -name "NewOrgName"
resutil editorg -orgname "Soar43-1" -name "SOAR47"
Environment
App Host
Resolving The Problem
- For applications deployed to the IBM Security QRadar SOAR App Host:
- Open the app.config in the SOAR UI by selecting Administrator Settings > Apps > {application} > Configuration tab.
- Locate the [resilient] section.
- Edit org = <old_org_name> to org = <new_org_name>.
For example, this old ORG name:
Changes to: - Repeat steps for each application.
- For applications deployed to the IBM Security QRadar SOAR Integration Server:
- Open the app.config file.
Note: The default location for the app.config file is:/home/integration/.resilient/app.config
- Edit the [resilient] section
- Changing org = <old_org_name> to org = <new_org_name>
- Open the app.config file.
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSA230","label":"IBM Security QRadar SOAR"},"ARM Category":[{"code":"a8m0z0000001jTpAAI","label":"Integrations-\u003EAppHost"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
06 February 2023
UID
ibm16857279