IBM Support

MaaS360 Packager version 1.47.000 auto-upgrade issue

Troubleshooting


Problem

The current production MaaS360 Packager, app version 1.47.000, has an internal issue with auto-upgrading. MaaS360 admins need to upgrade the app manually this one time to the 1.48.000 version, which will be released 24 January 2023.

Symptom

The prompt to ‘Download & Install’ update opens and loop every time logging to packager since the upgrade fails internally.
Update dialog box

Cause

The upgrade fails internally with an error that causes the upgrade to not finalize despite getting a successfully upgraded prompt.

Diagnosing The Problem

The UI says "Upgrade Completed" but prompts for upgrade on next login.
Upgrade complete prompt

Resolving The Problem

Download the MaaS360 Packager installer from MaaS360 Admin Portal and install the update manually. From the MaaS360 administrator portal, navigate to Apps -> Catalog -> Add -> Enterprise App for MacOS. Use the "Click here" link shown in the screen capture to download the SPB_Signed.pkg application. Once installed, log back into the packager by using portal administrator credentials and the upgrade prompt no longer appears.
Packager dl
Mac Packager Link

Document Location

Worldwide

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Document Information

Modified date:
23 January 2023

UID

ibm16856991