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OIDC Provider with authorization code flow stops processing on some browsers

Troubleshooting


Problem

I configure a reverse proxy instance as OIDC Provider with authorization code flow. The reverse proxy for OP is configured to use form login.
After I submit username and password on the login page, federation processing is stopped. The login page is remained on browser.
This issue is only observed on some of browsers such as Edge, Chrome. Not observed Firefox, Safari.

Cause

This issue is caused by browser's behavior. The browser stops processing without showing any errors.
This issue is depending on sequence of redirection after login.

Diagnosing The Problem

Enable browser's HAR trace and re-create the issue. You can find following sequence of requests.
  POST /pkmslogin.form
  GET <jct>/sps/auth
In HAR file, the response of second request would be failed such as
          "redirectURL": "https://<redirect-url>",
          "headersSize": -1,
          "bodySize": -1,
          "_transferSize": 0,
          "_error": "net::ERR_ABORTED"

Resolving The Problem

To change sequence of chain redirection after login, set following parameter in webseald.conf file.
[acnt-mgt]
enable-html-redirect = yes

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSESHP","label":"IBM Security Verify Access Appliance"},"ARM Category":[{"code":"a8m0z000000cxugAAA","label":"Security Verify Access-\u003EFederation"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
19 January 2023

UID

ibm16856379