IBM Support

IBM DOORS server connection timeout (database setting) and idle or stale sessions

Question & Answer


Question

Can the DOORS server connection time-out database setting be used to disconnect stale or idle users?

Cause

DOORS Client sessions can go stale or become idle for a number of reasons, including Terminal-Server and Citrix® issues or user error.
Releasing the licenses consumed or data locks placed by those sessions is a common administrative goal.

Answer

 No. The connection timeout feature is directed at the same machine and the same DOORS client session reconnecting to the DOORS Server.
It does not allow for reconnecting from to an existing DOORS client session from a different machine, or a new DOORS client instance on the same machine. 
 The purpose of this feature is to configure a period, within which a running DOORS client can attempt to reconnect to an existing DOORS client session during a network outage of limited duration. The client must not be closed or restarted between losing the connection and attempting to reconnect!
The most common scenario for this feature is changing network access methods, for example wired to wireless, access point to access point, etc pp.
 The connection timeout feature does not actively disconnect an otherwise valid DOORS client session after a set amount of time!



 

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"ARM Category":[{"code":"a8m50000000CipVAAS","label":"DOORS-\u003EServer Administration"}],"ARM Case Number":"TS011871498","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.7.2;and future releases"}]

Document Information

Modified date:
18 January 2023

UID

ibm16856123