IBM Support

TM1 instances/servers do not appear in Architect/Perspectives if you don't open as an administrator

Troubleshooting


Problem

Running TM1 instances do not appear in the list of available servers in Architect/Perspectives if you don't open them as an administrator

Symptom

TM1 servers do not appear in Architect/Perspectives unless you run them as an administrator 

Cause

The issue is likely triggered due to the TM1 server being configured to use custom certificates and the user not having Read and Execute permissions over the ibmtm1.kdb and ibmtm1.sth files. If you have used any custom names, then provide Read and Execute permission for the relevant file.

Resolving The Problem

Give the user Read and Execute permission over ibmtm1.kdb and ibmtm1.sth files. By default, the path of these files is PA installation directory tm1_64\bin64\ssl
Note: If the client you are running is 32-bit, then the path would be PA installation directory tm1_64\bin\ssl for the 64-bit client the path would be PA installation directory tm1_64\bin64\ssl

Document Location

Worldwide

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Document Information

Modified date:
03 January 2023

UID

ibm16852175