IBM Support

How To Uninstall IBM WebSphere Application Server v8.0 and Later and the Installation Manager Products on the IBM i OS

Troubleshooting


Problem

This document will discuss how to uninstall IBM WebSphere Application Server (WAS) v8.0 and later and Installation Manager products. It will also discuss how to preserve your WAS profiles if a reinstallation is required.

Cause

Uninstallation or reinstallation of the IBM WebSphere Application Server and/or Installation Manager product is needed.

Environment

IBM i, IBM WebSphere Application Server, IBM Installation Manager

Resolving The Problem

  • READ FIRST - How to Preserve Your IBM WebSphere Application Server Profiles Before Uninstallation

    Beginning in IBM WebSphere Application Server v8.0, the IBM Installation Manager product is now used to install and uninstall the IBM WebSphere Application Server software package. With the new categorization of software products as packages, all objects related to the package are removed from the system when the package is uninstalled from the Installation Manager product. For the IBM WebSphere Application Server product, this includes the product installation data and all profiles created under the installation.

    If a situation is encountered where the IBM WebSphere Application Server product needs to be re-installed and you wish to preserve your WAS profiles previously created, follow the steps listed below to do so. NOTE: These steps have to be performed prior to uninstalling the IBM WAS product package.

    1. Sign onto a 5250 emulation session with a user that has *ALLOBJ and *SECADM explicit special authorities.

    2. End all WebSphere application servers related to the installation you are about to uninstall.

    3. Create a save file to store the WAS profile IFS data.

    • CRTSAVF QGPL/WASPRFDTA
       
    4. Determine the Default Profile Location ($PROFILE_ROOT) for your WAS installation.

    • STRQSH
      <installRoot>/bin/queryWASinstalls

      i.e /QIBM/ProdData/WebSphere/AppServer/V85/Express/bin/queryWASinstalls

      OR (WASv8.0 and earlier)
      /QIBM/WAS/bin/queryWASinstalls

      Here is an example of the output from queryWASinstalls:
      The $PROFILE_ROOT variable is determined by the path set for the "Default Profile Locaiton".
      ----------------------------------------------------------------------------
      Websphere Edition:      EXPRESS
      Version:                8.5.5.1
      Installation Location:  /QIBM/ProdData/WebSphere/AppServer/V85/Express
      Installation Library:   QWAS85F
      Default Profile Location: /QIBM/UserData/WebSphere/AppServer/V85/Express
      ----------------------------------------------------------------------------
    • In this example, $PROFILE_ROOT=/QIBM/UserData/WebSphere/AppServer/V85/Express

    • 5. Save the IBM WAS Default Profile Location directory structure and its private authorities.

    • SAV DEV('/QSYS.LIB/QGPL.LIB/WASPRFDTA.FILE') OBJ(('$PROFILE_ROOT')) DTACPR(*HIGH) PVTAUT(*YES)

      i.e.
      SAV DEV('/QSYS.LIB/QGPL.LIB/WASPRFDTA.FILE') OBJ(('/QIBM/UserData/WebSphere/AppServer/V85/Express')) DTACPR(*HIGH) PVTAUT(*YES)

    • 6. Perform the uninstall and re-install of the IBM WebSphere Application Server product.

    • See the "How to Uninstall the IBM WebSphere Application Server V8.0 and later product" section for more information.

    7. After the IBM WebSphere Application Server product has been re-installed, determine the new "Default Profile Location" for the new installation.
    • STRQSH
      <installRoot>/bin/queryWASinstalls

      i.e /QIBM/ProdData/WebSphere/AppServer/V85/Express/bin/queryWASinstalls

      OR (WASv8.0 and earlier)
      /QIBM/WAS/bin/queryWASinstalls

      Here is an example of the output from queryWASinstalls:
      The $PROFILE_ROOT_NEW variable is determined by the path set for the "Default Profile Locaiton".
      ----------------------------------------------------------------------------
      Websphere Edition:      EXPRESS
      Version:                8.5.5.1
      Installation Location:  /QIBM/ProdData/WebSphere/AppServer/V85/Express
      Installation Library:   QWAS85F
      Default Profile Location: /QIBM/UserData/WebSphere/AppServer/V85/Express
      ----------------------------------------------------------------------------

      In this example, $PROFILE_ROOT_NEW=/QIBM/UserData/WebSphere/AppServer/V85/Express

    8. Restore the previously saved WAS profile data and its private authorities to the new Default Profile Location path.
    • RST DEV('/QSYS.LIB/QGPL.LIB/WASPRFDTA.FILE') OBJ(('$PROFILE_ROOT' *INCLUDE '$PROFILE_ROOT_NEW')) PVTAUT(*YES)

      i.e.
      RST DEV('/QSYS.LIB/QGPL.LIB/WASPRFDTA.FILE') OBJ(('/QIBM/UserData/WebSphere/AppServer/V85/Express' *INCLUDE '/QIBM/UserData/WebSphere/AppServer/V85/Express')) PVTAUT(*YES)

    9. Your IBM WebSphere Application Server profile data is now successfully restored. You can now start your application servers to ensure they function properly.

  • How to Uninstall IBM WebSphere Application Server V8.0 and Later


    NOTE: Following this process will uninstall the IBM WebSphere Application Server product and any WAS profiles that were created under this installation. If you wish to preserve your WAS profiles, please refer to the "How to Preserve Your IBM WebSphere Application Server Profiles Before Uninstallation" section before following the steps in this section.

    The following steps will uninstall the IBM WebSphere Application Server product and any associated WAS profiles for this installation:

    1. Sign onto a 5250 green screen using a profile that has *ALLOBJ and *SECADM explicit special authorities.

    2. Start a Qshell Interpreter session.

    • STRQSH

    3. Identify the package name and installation directory of the IBM WebSphere Application Server version you wish to uninstall. NOTE: If you experience errors with the IMCL command or believe your InstallationManager product is corrupted, proceed to step 4 on how to manually clean up your WAS installation.
    • a) Execute the following commands in Qshell:
      • cd /qibm/proddata/installationmanager/eclipse/tools
          $
        > umask 022          
          $                          
        > ./imcl listInstalledPackages -long
                                                   
          /QIBM/ProdData/InstallationManager/eclipse : com.ibm.cic.agent_1.7.0.20130828_2012 : IBM® Installation Manager : 1.7.0

        /QIBM/ProdData/WebSphere/AppServer/V8/Express : com.ibm.websphere.EXPRESS.v80_8.0.7.20130725_2248 : IBM WebSphere Application Server - Express : 8.0.0.7

        /QIBM/ProdData/WebSphere/AppServer/V85/Express : com.ibm.websphere.WEBENAB.v85_8.5.5001.20131018_2242 : IBM Web Enablement for IBM i : 8.5.5.1

      b) Locate the IBM WebSphere Application Server software package you would like to uninstall.
      • In the above example, the packages com.ibm.websphere.EXPRESS.v80 and com.ibm.websphere.WEBENAB.v85 are shown as currently installed.

        Other packages may include the following:
        • com.ibm.websphere.WEBENAB.V80
          com.ibm.websphere.BASE.v80
          com.ibm.websphere.ND.v80
          com.ibm.websphere.EXPRESS.v85
          com.ibm.websphere.BASE.v85
          com.ibm.websphere.ND.v85
          com.ibm.websphere.BASE.v90
          com.ibm.websphere.ND.v90

        In my example, $PACKAGE = com.ibm.websphere.WEBENAB.v85.

      c) Identify the installation directory from the "imcl listInstalledPackages -long" output for the software package you wish to uninstall.
      • /QIBM/ProdData/WebSphere/AppServer/V85/Express : com.ibm.websphere.WEBENAB.v85_8.5.5001.20131018_2242 : IBM Web Enablement for IBM i : 8.5.5.1

        In my example, $INSTALL_DIR = /QIBM/ProdData/WebSphere/AppServer/V85/Express

        The following command will uninstall the IBM WebSphere Application Server product based on the package and installation directory information provided.

        ./imcl uninstall $PACKAGE -installationDirectory $INSTALL_DIR

        For example, the following command will uninstall the com.ibm.websphere.WEBENAB.v85 package in the /QIBM/ProdData/WebSphere/AppServer/V85/Express installation directory.

        ./imcl uninstall com.ibm.websphere.WEBENAB.v85  -installationDirectory  /QIBM/ProdData/WebSphere/AppServer/V85/Express  
         Uninstalled com.ibm.websphere.WEBENAB.v85_8.5.5001.20131018_2242 from the /QIBM/ProdData/WebSphere/AppServer/V85/Express directory.
         $
        ./imcl listInstalledPackages -long                                                                                                 /QIBM/ProdData/InstallationManager/eclipse : com.ibm.cic.agent_1.5.1000.20111128_0824 : IBM® Installation Manager : 1.5.1  
        $    

      d) Looking at the output above, you can now see the IBM WebSphere Application Server package has been removed.

    4. In addition to the execution of the "imcl uninstall" command, there are some directories and libraries that need to be manually deleted.
    • To manually delete these directories and libraries, you should do the following:
      a) Determine the WAS Installation Library:

      STRQSH
      <installRoot>/bin/queryWASinstalls

      i.e /QIBM/ProdData/WebSphere/AppServer/V85/Express/bin/queryWASinstalls

      OR (WASv8.0 and earlier)
      /QIBM/WAS/bin/queryWASinstalls

      Here is an example of the output from queryWASinstalls:
      The $INSTALL_LIB variable is determined by the library name set for the "Installation Library".

      ------------------------------------------------------------------------
      Websphere Edition:      EXPRESS
      Version:                8.5.5.1
      Installation Location:  /QIBM/ProdData/WebSphere/AppServer/V85/Express
      Installation Library:   QWAS85A
      Default Profile Location: /QIBM/UserData/WebSphere/AppServer/V85/Express
      ------------------------------------------------------------------------

      $INSTALL_LIB = QWAS85A

      NOTE: This script may fail if the required JDK version is not installed. If the queryWASinstalls script fails to execute because the JDK version cannot be found, you can edit the queryWASinstalls script and modify the JAVA_HOME environment variable value to a currently installed JDK version and bit level to resolve your issue.

      WRKLNK '/QIBM/WAS/bin/queryWASinstalls'
      Option 2 to edit.
      Locate and modify the JAVA_HOME value to an installed JDK version and bit level.
      i.e. JAVA_HOME=/QOpenSys/QIBM/ProdData/JavaVM/jdk80/32bit
      Press F3 twice to save and exit. Then, execute the queryWASinstalls script again.
      b) Press F12 to exit Qshell.
      c) Delete the WAS Product and Installation Libraries.

      DLTLIB LIB($INSTALL_LIB)

      i,e, DLTLIB LIB(QWAS85A)

      $PROD_LIB = QWAS8 (WAS v.8.0), QWAS85 (WAS v8.5.5), or QWAS9 (WAS v9.0)

      DLTLIB LIB($PROD_LIB)

      i.e. DLTLIB LIB(QWAS85)
      c) Issue the STRQSH command.
      d) Issue the following command based on what you want to remove from your system:

      - If you only want to remove the specific edition of WAS, execute the following commands:
      NOTE: This is usually the case when you have multiple editions installed and only want to uninstall one of the editions under a specific version.
      • rm -R /QIBM/ProdData/WebSphere/AppServer/<version>/<edition>

        Optional: If you wish to delete the WebSphere Application Server Profiles, you should issue the following command:

        rm -R /QIBM/UserData/WebSphere/AppServer/<version>/<edition>
      • <version> = V8, V85, or V9
        <edition> = Express, Base, or ND

      • - If you want to remove the entire version of WAS from your system, execute the following commands.

      NOTE: This will delete all editions for this version of WAS from your system.
      • rm -R /QIBM/ProdData/WebSphere/AppServer/<version>

        Optional: If you wish to delete the WebSphere Application Server Profiles, you should issue the following command:

        rm -R /QIBM/UserData/WebSphere/AppServer/<version>
      • <version> = V8, V85, or V9

      • - If this is the only version and edition of WAS on your system AND you wish to delete the WebSphere Application Server product entirely off of your system, execute the following commands.

      • rm -R /QIBM/ProdData/WebSphere

        Optional: If you wish to delete the WebSphere Application Server Profiles, you should issue the following command:

        rm -R /QIBM/UserData/WebSphere

  • How to Uninstall the IBM InstallationManager (Optional)

    Important Note: Before you can uninstall the IBM Installation Manager product, you must uninstall all packages currently installed under the InstallationManager product.
    NOTE: These steps only need to be done if you are removing the all IBM WebSphere Application Server products from the IBM i server.

    To uninstall the IBM InstallationManager, execute the following commands:
    • a) Execute the STRQSH command.
      b) Execute the following command inside of Qshell:
      • cd /qibm/userdata/installationmanager/uninstall            
        $
        ./uninstallc      
         Uninstalled com.ibm.cic.agent_1.5.1000.20111128_0824 from the /QIBM/ProdData/InstallationManager/eclipse directory.
        $
        rm -r /QIBM/ProdData/InstallationManager
        $
        rm -r /QIBM/UserData/InstallationManager
        $
        rm -r /QIBM/InstallationManager
        $
        rm -r /QIBM/UserData/IMShared
        $

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000CJaAAM","label":"WebSphere Application Server-\u003EUninstall"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.1.0;7.2.0;7.3.0;7.4.0;7.5.0;and future releases"}]

Historical Number

625491752

Document Information

Modified date:
19 December 2023

UID

nas8N1011125