IBM Support

Maximo Mobile SAML authentication fails.

Troubleshooting


Problem

Attempting to log in to the Maximo Mobile application that uses SAML, the IDP authentication passes. However the login to the application fails with a Connect/Authentication failed message.

Symptom

After you're presented the Identity Provider login screen and enter your credentials you are redirected to application, which displays displays the following error.
Connect/Authentication failed

Cause

The error can be caused by improper use of the maximo.mobile.ldap.isForm property that is required for Maximo Mobile LDAP authentication.  When this property is set along side the mxe.useSAML property, it attempts to authenticate any subsequent transactions after entering the application through an LDAP connection and not SAML.

Diagnosing The Problem

To confirm this error is your problem, you can review the Maximo logs; The logs show an error similar to the following attempting to authenticate your user by using the WebSphere federated repository configuration and not finding the user as it doesn't exist locally. 
00000111 LTPAServerObj E   SECJ0369E: Authentication failed when using LTPA. The exception is com.ibm.websphere.wim.exception.PasswordCheckFailedException: CWWIM4537E  No principal is found from the 'MAXADMIN' principal name..
00000111 FormLoginExte E   SECJ0118E: Authentication error during authentication for user MAXADMIN

Resolving The Problem

To resolve this issue, if using SAML for authentication, you need to ensure the following properties are set to the values below then attempt to use the mobile app again.
 maximo.mobile.ldap.isForm = 0
 mxe.useSAML=1

Document Location

Worldwide

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Document Information

Modified date:
06 December 2022

UID

ibm16843977