IBM Support

QRadar: DRBD split-brain とは何でしょうか ?

Question & Answer


Question

DRBD split-brain とは何でしょうか。またなぜそれは問題なのでしょうか ? そしてそれはどのように解決できるでしょうか ?

Cause

スプリット・ブレインとはは、クラスタ・ノード間のネットワーク・リンクに障害が発生している間に、クラスタ管理ソフトウェアによる介入や人的ミスによって引き起こされ、切断された状態で両方のノードがプライマリーに切り替わること状態を指します。

Answer

スプリット ・ブレインは、高可用性ノードが切断されている間に両方がプライマリー・ロールに切り替わった場合に発生します。 この動作により、どちらかのノードでデータが変更されても対向ノードに複製されず、各ノードで 2 つのデータ・セットが分岐してしまい、マージが困難になる場合があります。

重要: スプリット・ブレインが発生している場合、システムがダウンした際にフェイルオーバーができず、正しく複製されないためデータが失われる可能性があります。これは深刻な問題であるため、すぐに対処しなければなりません。
スプリット・ブレインの見分け方
  1. QRadar コンソールに SSH 接続します。
  2. 次のコマンドを使用して、HA の状態を確認します。:
    cat /proc/drbd
  3. 両方のホストがスタンドアロン状態、または片方がスタンドアロンでもう片方が WFConnection の場合、これはスプリット・ブレインの状態である可能性があります。
  4. /var/log/message ログで文字列 "Split-Brain detected" を検索します。
    grep "Split-Brain detected" /var/log/message.log

    結果
    もし次のようなメッセージが表示された場合は、スプリット・ブレインの状態であるといえます。:
    Generic-primary kernel: block drbd0: Split-Brain detected but unresolved, dropping connection!
スプリット・ブレインになったらどうすればよいでしょうか。
caseを重要度 1 として引き上げることを検討し、サポートに連絡、両方のホストの ログを提供 してください。  チームは、どちらの高可用性ノードが有効なデータを持っているかを特定する必要があります。通常は、最後にアクティブになったノードです。

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000cwtXAAQ","label":"High Availability"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
31 January 2023

UID

ibm16841779