Troubleshooting
Problem
The QRadar installation (/media/updates/installer) fails at the precheck stage with the "Patch pretest 'HA Mountpoint Check' failed" error.
Symptom
The following error is observed during the patch or upgrade process, or it can be found in the patches.log:
Patch pretest 'HA Mountpoint Check' failed. (checkMountPointForHa.sh)
'
Status Summary of Hosts
+-------------------------+-----------------+
|Hostname |Status |
|-------------------------+-----------------|
|test-hostname |Patch Test Failed|
+-------------------------+-----------------+
[DEBUG]Patch Report for XX.XX.XX.XX, appliance type: 3199
Patch pretest 'HA Mountpoint Check' failed. (checkMountPointForHa.sh)
test-hostname : patch test failed.
Cause
The sfs file is mounted in a different path than /media/patch or /media/updates, or the file name is not right, for example, /media/update instead of /media/updates.
Resolving The Problem
- SSH into the QRadar console.
- Optional: If the issue is on a host different than the console, SSH to that managed host.
- Identify the wrong mountpoint. Run the following command:
df -Th | grep -i squashfs
- Unmount patch or upgrade file. Change <mount_point_path> with the path given in the previous command:
umount <mount_point_path>
- Rename the folder to /media/updates. Run the following command:
mv /media/<folder name> /media/updates
Mount the patch or upgrade file. Replace <patch_or_upgrade_file>.sfs with the .sfs file name:mount -o loop -t squashfs /storetmp/<patch_or_upgrade_file>.sfs /media/updates
- Run the installer:
/media/updates/installer
Result
The administrator is able to install or update QRadar without any error. If the error persists, contact QRadar Support for assistance.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSV4BL","label":"IBM QRadar"},"ARM Category":[{"code":"a8m0z000000cwtdAAA","label":"Upgrade"}],"ARM Case Number":"TS011190872","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
21 November 2022
UID
ibm16840187