Troubleshooting
Problem
The snowflake for the Impact console integration in DASH is not displayed after upgrading Impact 7.1.0.26 or 7.1.0.27.
Symptom
The "snowflake" icon in the DASH navigation ribbon for the Impact console integration is not displayed.
The ImpactUI messages.log contains messages like:
[11/9/22 15:10:24:203 EST] 0000045a com.ibm.ws.security.token.internal.TokenManagerImpl I CWWKS4001I: The security token cannot be validated. This can be for the following reasons
1. The security token was generated on another server using different keys.
2. The token configuration or the security keys of the token service which created the token has been changed.
3. The token service which created the token is no longer available.
With WebSphere security traces enabled, the following additional related message is written in the ImpactUI trace.log:
[11/10/22 11:20:13:519 GMT] ... com.ibm.ws.security.token.ltpa.internal.LTPAToken2 3 Invalid signature of the token ... [11/10/22 11:20:13:519 GMT] ... com.ibm.ws.security.token.internal.TokenManagerImpl 3 The token service com.ibm.ws.security.token.ltpa.internal.LTPATokenService@4e41063a failed to recreate the token. com.ibm.websphere.security.auth.InvalidTokenException: Token Validation Failed
Cause
Impact fix packs 7.1.0.26 and 7.1.0.27 include WebSphere Liberty versions 20.0.0.6 - 20.0.0.8 respectively, and are affected by APAR PH48187. The APAR details and the corresponding iFix are included in the following documentation link:
Resolving The Problem
This issue is fixed in Impact fix pack 7.1.0.28.
For Impact versions 7.1.0.26 and 7.1.0.27, apply the following:
1) Create a backup of the full Impact installation directory (/opt/IBM/tivoli/impact).
2) Download the "22006-wlp-archive-IFPH48187" (Impact 7.1.0.26) or "22008-wlp-archive-IFPH48187" (Impact 7.1.0.27) package from IBM fix Central:
22006-wlp-archive-IFPH48187:
https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%2FWebSphere&product=ibm/WebSphere/WebSphere+Liberty&release=All&platform=All&function=fixId&fixids=22006-wlp-archive-IFPH48187&includeSupersedes=0
https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%2FWebSphere&product=ibm/WebSphere/WebSphere+Liberty&release=All&platform=All&function=fixId&fixids=22006-wlp-archive-IFPH48187&includeSupersedes=0
22008-wlp-archive-IFPH48187:
https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%2FWebSphere&product=ibm/WebSphere/WebSphere+Liberty&release=All&platform=All&function=fixId&fixids=22008-wlp-archive-IFPH48187&includeSupersedes=0
https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%2FWebSphere&product=ibm/WebSphere/WebSphere+Liberty&release=All&platform=All&function=fixId&fixids=22008-wlp-archive-IFPH48187&includeSupersedes=0
3) Copy the "2200x-wlp-archive-ifph48187.jar" file to the following directory on the Impact server:
/opt/IBM/tivoli/impact/
4) As the OS user you used to install Impact, execute the following command in the /opt/IBM/tivoli/impact/ directory:
/opt/IBM/tivoli/impact/sdk/bin/jre/java -jar 2200x-wlp-archive-ifph48187.jar
5) If the iFix is installed without error, restart the Impact server (NCIP01) and ImpactUI server processes.
Document Location
Worldwide
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Document Information
Modified date:
14 December 2022
UID
ibm16839545