Troubleshooting
Problem
After creating a new keystore file and changing the keystore file for IBM Engineering Requirements DOORS Web Access(DWA), accessing DWA results in "Unable to connect" error.
Symptom
Symptom #1: Accessing DWA (for example, https://localhost:8443/dwa) results in "Unable to connect" error
Symptom #2: Catalina log shows that the keystore file cannot be found
In catalina log under <DWA_Home>\server\logs directory
(for example, C:\IBM\DWA\server\logs\catalina.2022-10-12.log)
You can see the following
Caused by: java.io.FileNotFoundException: C:\IBM\DWA\server\MyDWAKey.keystore (The system cannot find the file specified.)
Cause
The keystore file specified in server.xml is not found under <DWA_Home>\server directory.
Diagnosing The Problem
1) Find out the keystore file that is used by DOORS Web Access
Check the line containing keystoreFile= in server.xml
for example, keystoreFile="MyDWAKey.keystore"
2) Check whether the keystore file specified in server.xml is under <DWA_Home>\server directory
It is possible that there is spelling error in the keystore file name.
Example #1:
server.xml: keystoreFile="MyDWAKey.keystore"
the actual keystore file under <DWA_Home>\server: MyDWAKey.store
Example #2:
server.xml: keystoreFile="MyDWAKey.keystore"
the actual keystore file under <DWA_Home>\server: DWAKey.keystore
Resolving The Problem
Make sure that the keystore file specified in the server.xml exists under <DWA_HOME>\server directory
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"ARM Category":[{"code":"a8m50000000CiqdAAC","label":"DOORS-\u003EDOORS Web Access (DWA)"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Product Synonym
DOORS; DWA
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Document Information
Modified date:
17 September 2024
UID
ibm16839399