Troubleshooting
Problem
When the Maximo Manage Database password is changed, the change does not automatically take effect.
Symptom
When the Maximo Manage database password is changed through the Maximo Application Suite user interface, the maxinst pod and the server bundle pods are not restarting to pick up the new password.
In some cases when the pods restart, it is possible they restart with the old password and fail to connect to the database.
Cause
There are two possible problems:
- The Maximo Application Suite failed to re-create the configmap that triggers the Maximo Manage reconcile that causes the password to be updated in manage and the pods to restart with the new password.
- Maximo Manage failed to reconcile after the reconcile configmap was re-created.
Resolving The Problem
Log in to the Red Hat OpenShift console. Under the Workload section, select ConfigMaps. Select the manage project on the Name field and search for "jdbccfg-binding-reconcile".
if the Created date and time are before the time the database user or password were changed then to work around the problem delete the configmap, a new one is created in a couple of minutes and that triggers a reconcile that updates the password in the manage workspace.
If the configmap Created date and time were after the database user or password were changed and the pods didn't restart, it means that Maximo Manage failed to reconcile, this behavior is covered in this technote https://www.ibm.com/support/pages/node/6839531.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
06 December 2022
UID
ibm16839153