Troubleshooting
Problem
AWSのマーケットプレースのAMIを使用してISVAを導入した。LMIのログイン画面にアクセスできたが、adminユーザーでログインできない。設定されているはずのパスワードであるAWSのインスタンスID、および通常のアプライアンスの初期パスワード admin のどちらでもログインできない。
Cause
AMIをインストールしたときのAWSインスタンスのメタデータ・バージョンがV2のみになっている可能性があります。
Diagnosing The Problem
AWSインスタンスのメタデータ・バージョンを確認します。
Resolving The Problem
マーケットプレースのAMIをインストールする際には、メタデータ・バージョンV1が有効になっている必要があります。そのため、インストール時点のみメタデータ・バージョンをV1&V2に設定し、インストール後にV2のみに変更します。手順は次のとおりです。
- AWSインスタンスをメタデータ・バーション V1&V2 で作成します。
- AMIをインストールします。
- LMIへログインします。この時のパスワードはインスタンスIDとなります。
- LMIでadminユーザーのパスワードを変更します。
- AWSインスタンスのメタデータ・バージョンを V2 に変更します。
次のコマンドでメタデータ・バージョンをV2に変更することができます。
aws ec2 modify-instance-metadata-options --instance-id i-xxxxxx --http-tokens required --http-endpoint enabled
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSESHP","label":"IBM Security Verify Access Appliance"},"ARM Category":[{"code":"a8m0z000000cxuHAAQ","label":"Security Verify Access"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
11 November 2022
UID
ibm16838781