Troubleshooting
Problem
msgCPI096E - Disk unit connection is missing.
*Note: This message can be issued even though all of your disk paths appear to be correct.
Cause
If disk paths were defined and at one time presented to the IBM i, then the IBM i expects these paths until they are properly cleaned up. Dynamic changes or removal of the disk paths can result in the CPI096E messages
*Note: CPI096E message is normal and expected for Full System FlashCopy (FSFC) and iASP Flashcopy. If you are using the iASP FlashCopy Toolkit, then the toolkit automatically runs the MULTIPATHRESETTER macro to clean up the disk paths. If you are performing a full system FlashCopy or no FlashCopy at all, then the MULTIPATHRESETTER macro is not automatically issued.
Environment
IBM i with or without FlashCopy
Diagnosing The Problem
Verify that your disk units have the correct number of Active or Passive paths and that none are MISSING or FAILED:
1. STRSST and sign in
2. Option 3. Work with disk units
3. Option 1. Display disk configuration
4. Option 9. Display disk path status
1. STRSST and sign in
2. Option 3. Work with disk units
3. Option 1. Display disk configuration
4. Option 9. Display disk path status
*Note: If no disk resources show, then only 1 disk path exists and there is no multipath redundancy; disk unit resources can show as DDxxx if never set up with multipath.
Alternatively, with IBM i 7.3 or above, you could STRSQL and run the following:
SELECT * FROM QSYS2.SYSDISKSTAT ORDER BY UNIT_NUMBER
*Note: Newer OS releases and Technology levels add IOP, WWPNs, hardware status, etc: https://www.ibm.com/support/pages/node/1136104)
SELECT * FROM QSYS2.SYSDISKSTAT ORDER BY UNIT_NUMBER
*Note: Newer OS releases and Technology levels add IOP, WWPNs, hardware status, etc: https://www.ibm.com/support/pages/node/1136104)
*Note: If the environment is not a FlashCopy environment or your disk paths are still not correct, then there should be further investigation. When disk or paths are not being presented to the IBM i, it is highly likely to be a zoning issue. However, you may need to also check other involved areas such as IBM i virtual adapters, VIOS configuration if involved, physical adapters/ports, cables, SFPs, switches, zoning, storage nodes/ports, storage configuration such as hosts or target port modes (SVC/Storwize) or read/write protection or masking, etc
Resolving The Problem
Delete any non-reporting disk resources:
1. STRSST and sign in
2. Option 1. Start a service tool
3. Option 7. Hardware service manager
4. Option 4. Failed and non-reporting hardware resources
5. Select 4=Remove for any disk (DMPxx or DDxx) related resources and press enter
1. STRSST and sign in
2. Option 1. Start a service tool
3. Option 7. Hardware service manager
4. Option 4. Failed and non-reporting hardware resources
5. Select 4=Remove for any disk (DMPxx or DDxx) related resources and press enter
After deleting non-reporting disk resources, run the MULTIPATHRESETTER macro
The MULTIPATHRESETTER macro can be run to clean up old disk paths or when there are more disk paths than what is expected. This macro can be ran non-disruptively while the users are on the system. Also, any new or re-attached disk paths afterwards are automatically re-discovered.
1. STRSST and sign in
2. Option 1. Start a service tool
3. Option 4. Display/Alter/Dump
4. Option 1. Display/Alter storage
5. Option 2. Licensed Internal Code (LIC) data
6. Option 14. Advanced analysis
7. Enter the following data and then press enter:
1 MULTIPATHRESETTER
8. Enter the following data and press enter:
Options . . . . . -RESETMP -ALL
9. Press enter to go back to the Options parameter
10. Change to the following data and press enter:
Options . . . . . -CONFIRM -ALL
2. Option 1. Start a service tool
3. Option 4. Display/Alter/Dump
4. Option 1. Display/Alter storage
5. Option 2. Licensed Internal Code (LIC) data
6. Option 14. Advanced analysis
7. Enter the following data and then press enter:
1 MULTIPATHRESETTER
8. Enter the following data and press enter:
Options . . . . . -RESETMP -ALL
9. Press enter to go back to the Options parameter
10. Change to the following data and press enter:
Options . . . . . -CONFIRM -ALL
*Note: For FlashCopy environments, you can add the QSRDHASM/RESETMPATH command to your startup program.
If the paths are not correct afterwards, then please create an IBM support case and collect the IBM i SYSSNAP, VIOS snaps (if involved), switch data, and storage data to attach to your support case.
A) IBM i SYSSNAP:
A1) QMGTOOLS/CMPVER, press enter, F6 to automatically download and process the latest update
A2) QMGTOOLS/SYSSNAP OUTPUT(*IFS) COLLECTDFT(Y) LICLOGS(Y) PALS(Y) QHST(Y) DAYSPRV(1)
*Note1: Change the DAYSPRV to the number of previous days to capture the issue. Do not go past 10 days. Instead, use a the date range to minimize collections.
*Note2: When the SYSSNAP completes, the link to the data is listed at the bottom of the screen. Copy that file path for the next step.
A3) QMGTOOLS/FTP2IBMCMD INPUT(*IFS) CASENBR(TSxxxxxxxxx) IFSFILE('/tmp/xxxxx.zip)
*Note: replace the /tmp/xxxxx.zip with the directory file of the SYSSNAP. Alternatively, you can use the GO QMGTOOLS/MG option 10.
*Note: FTP now requires a Transfer ID/Password. If you don't already have one, then you can generate one at the following by clicking the 'Generate new transfer ID' button:
https://www.secure.ecurep.ibm.com/transferids/
A1) QMGTOOLS/CMPVER, press enter, F6 to automatically download and process the latest update
A2) QMGTOOLS/SYSSNAP OUTPUT(*IFS) COLLECTDFT(Y) LICLOGS(Y) PALS(Y) QHST(Y) DAYSPRV(1)
*Note1: Change the DAYSPRV to the number of previous days to capture the issue. Do not go past 10 days. Instead, use a the date range to minimize collections.
*Note2: When the SYSSNAP completes, the link to the data is listed at the bottom of the screen. Copy that file path for the next step.
A3) QMGTOOLS/FTP2IBMCMD INPUT(*IFS) CASENBR(TSxxxxxxxxx) IFSFILE('/tmp/xxxxx.zip)
*Note: replace the /tmp/xxxxx.zip with the directory file of the SYSSNAP. Alternatively, you can use the GO QMGTOOLS/MG option 10.
*Note: FTP now requires a Transfer ID/Password. If you don't already have one, then you can generate one at the following by clicking the 'Generate new transfer ID' button:
https://www.secure.ecurep.ibm.com/transferids/
B) VIOS snap from BOTH VIO Servers (if VIOS is involved):
C) Switch logs:
Brocade: Supportsave
https://www.ibm.com/support/pages/how-collect-supportsave-brocade-switch
Brocade Command:
supportsave
Video on collecting SupportSave Data: https://www.ibm.com/support/pages/node/6258099
http://www-01.ibm.com/support/docview.wss?uid=isg3T1013064
C) Switch logs:
Brocade: Supportsave
https://www.ibm.com/support/pages/how-collect-supportsave-brocade-switch
Brocade Command:
supportsave
Video on collecting SupportSave Data: https://www.ibm.com/support/pages/node/6258099
Cisco Switch: Show Tech and Logging onboard
https://www.ibm.com/support/pages/node/691279
https://www.ibm.com/support/pages/node/691279
D) External Storage:
Storwize and Flash Systems: Support package > Type 4 - Standard logs plus new statesaves
V.8 and above:
Settings -> Support -> Support package -> Manual upload instructions ->Download Support Package
V.7:
Settings -> Support ->Download Support Package
V.8 and above:
Settings -> Support -> Support package -> Manual upload instructions ->Download Support Package
V.7:
Settings -> Support ->Download Support Package
DS8K:
statesave, PE package, and ODD
statesave, PE package, and ODD
Document Location
Worldwide
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Document Information
Modified date:
14 February 2024
UID
ibm16833860