Troubleshooting
Problem
We are witnessing frequent restart of the STAP, and no logs are generated for this event.
Symptom
S-TAP restarting
Cause
CPU_LOAD_LIMIT in resmon.ini might be set too low.
Diagnosing The Problem
Disabling the "IBM Security Guardium Resource Monitor Service"
Restart the STAP to see whether it stays up. If it does, then the Resource Monitor is the culprit.
Restart the STAP to see whether it stays up. If it does, then the Resource Monitor is the culprit.
Resolving The Problem
If that's the case, then the limits for that machine are set too low in the resmon.ini and those values need to be increased.
Focus on the CPU limit. This value assumes for a 1 core machine. If there are multiple cores, this can be set much higher.
On a multi-core system, this threshold can be raised to 150% or more on a 4-core system.
See the following doc for guidance:
Windows: Monitoring with the Guardium Agent Monitor
https://www.ibm.com/docs/en/guardium/11.4?topic=performance-windows-monitoring-guardium-agent-monitor
Windows: Monitoring with the Guardium Agent Monitor
https://www.ibm.com/docs/en/guardium/11.4?topic=performance-windows-monitoring-guardium-agent-monitor
If the problem still persists, provide the following information to Guardium Support for further analysis.
From the Collector:
"support must_gather sniffer_issues"
"support must_gather network_issues"
"support must_gather sniffer_issues"
"support must_gather network_issues"
From the DB host
Full STAP diag
Full STAP diag
Related Information
Document Location
Worldwide
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Document Information
Modified date:
26 October 2022
UID
ibm16832098