IBM Support

IBM Security Guardium - Cannot add new datasource after upgrading to 11.5

Troubleshooting


Problem

After upgrading from Guardium v11.0 or v11.1 to v11.5, new datasources cannot be created from GUI datasource definitions page.
Update - The problem also occurs after upgrading to 11.5 from any v11 appliance with sniffer patch below v11.0p4052

Symptom

When creating a new datasource or cloning an existing one an error appears in GUI - "A datasource with this name already exists". However, no datasource with that name is visible in datasource definitions page.

Cause

The auto increment of internal datasource table ID is set incorrectly when upgrading from v11, v11.1 or any v11 with sniffer patch below v11.0p4052 to v11.5.

Resolving The Problem

Before upgrade
To avoid problem after upgrade to v11.5, install latest v11 sniffer patch on the appliance.
  • Sniffer patch v11.0p4052 and above resolve the problem
After upgrade 
If appliance is already on v11.5. Install one of:
  • Sniffer patch v11.0p4052 and above
  • Latest bundle patch 
  • Ad hoc patch SqlGuard-11.0p1197.tgz.enc.sig 
    • Patch name Md5sum Download
      SqlGuard-11.0p1197.tgz.enc.sig 8068e8729b501cbfc9dbbfd238b98bef SqlGuard-11.0p1197.tgz.enc_.sig_.zip
      1. Extract the attached patch file
      2. Install on the central manager and all managed units
  • Do not install sniffer patch below v11.0p4052
If the problem is not resolved, contact Guardium support

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"ARM Category":[{"code":"a8m0z0000000CeYAAU","label":"DATA SOURCES"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.5.0"}]

Document Information

Modified date:
17 April 2023

UID

ibm16827921