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Automation Document Processing spbackend pods timeout after five minutes

Troubleshooting


Problem

When you are deploying or upgrading Automation Document Processing, the spbackend pods never come up running and ready.  Every five minutes, the pod logs show
WORKER TIMEOUT
 

Cause

At startup, the spbackend pods go through all the project databases and clean up old files and logs.  If there are many project databases, this process can take longer than the default five minute timeout for the pod.

Environment

Cloud Pak for Business Automation 22.0.1 or older.

Resolving The Problem

In the custom resource (CR) yaml, increase the timeout to thirty minutes or to a wanted value and then apply the yaml.
ca_configuration: 
  spbackend: 
    timeout: 1800

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBYVB","label":"IBM Cloud Pak for Business Automation"},"ARM Category":[{"code":"a8m3p000000hAKPAA2","label":"Operate-\u003EADP Install\\Upgrade\\Setup"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
10 February 2023

UID

ibm16827771