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QRadar: Delete files or directories to gain space in /transient partition

Troubleshooting


Problem

When the /transient partition in QRadar does not have enough space, it can affect the regular functioning of QRadar® SIEM. The purpose of this article is to help the administrator with the removal of files and directories when the /transient partition has not enough available disk space.

Symptom

Lack of available space in the /transient partition can cause the following issues:
 
  • Alerts about "Process monitor application failed to start multiple times".
  • Searches reporting I/O errors.
  • Services not starting.
  • Configuration deployment changes due to critical disk space.
    [tomcat.tomcat] /console/JSON-RPC/QRadar.scheduleDeployment QRadar.scheduleDeployment] com.q1labs.configservices.util.ConfigServicesUtil: 
    [INFO] [-/--] Deployment is blocked due to critical disk space issue
  • Failed disk space checks when a software update runs.
  •  [INFO](testmode) Checking Disk Space...
    [ERROR](testmode) /transient has 153417728 Kb needed and only 124856540 Kb available
    [ERROR](testmode) Usage Report:
    
    =-= DiskSpace Report for Mountpoint '/transient' =-=
    =-= Available: 124856540 Kb,  Required: 153417728 KB =-=

Cause

By default, the QRadar disk sentry check runs every 60 seconds and looks for high disk usage across the partitions. When a partition goes beyond the critical warning threshold, an alert is triggered for administrators to investigate.

Diagnosing The Problem

Follow both diagnosis sections and complete the Resolving the Problem steps for the issues confirmed in the conflicting appliance.
Appliances with undersized disks
Appliances can have undersized disks when the /transient partition does not exist and its contents are placed inside the root (/) partition instead. For more information about why this symptom occurs, see QRadar: Installing QRadar on appliances with several disks.
 
  1. SSH to the Console. If applicable, SSH to the managed host.
  2. Use the lsblk command to find out whether the disk size is less than 256GB and the /transient partition does not exist.
    lsblk
    In this example, the /transient partition does not exist which means it is inside the "/" partition:

    Figure01
Identify and delete large directories and files in the /transient partition.
 
If the appliance has a disk allocation that meets the storage requirements and the /transient  is mounted as a separate partition, the administrators can identify the largest directories and files by following the steps in Troubleshooting disk space usage problems.
Once these large directories are identified, follow the instructions in Resolving the Problem to remove them.

Resolving The Problem

Follow the steps in Diagnosing the Problem to determine whether you must complete the instructions under Appliances with undersized disks or Identify and delete large directories and files in the /transient partition. If both issues appear on your appliance, follow both sections.
 
Appliances with undersized disks
 
Administrators with disks that do not meet the storage requirements, must reinstall their systems by following the steps in QRadar: Delete files or directories to gain space in the / partition.
Identify and delete large directories and files in the /transient partition
 
Use the following instructions to identify safe to remove files and regain space.
Depending on the directory reported during diagnosis, follow the suggestions provided. You might follow some or all of the suggestions, depending on your needs.
  1. Searches in /transient/ariel_proxy.ariel_proxy_server/data.
  2. Data in /transient/spillover.
  3. Manual user files.
    • Remove any placed file that uses /transient as backup directory.
Result
The /transient partition no longer has disk space constraints. If the partition reached the point of critical services stop, restart the services in the proper order and wait 5 mins with the following commands:
 
IMPORTANT: When the QRadar core service restart, the QRadar UI, event processing, and database are not available to all users. Administrators with strict outage policies are advised to complete the next step during a scheduled maintenance window for their organization.
 
systemctl stop hostcontext
systemctl stop tomcat
systemctl restart hostservices
systemctl start tomcat
systemctl start hostcontext
If the partition does not decrease its usage or the services do not start properly, contact QRadar Support for assistance.

Document Location

Worldwide

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Document Information

Modified date:
30 September 2022

UID

ibm16825335