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Cognos Analytics Query Service JVM Metrics values not updating, showing as 0.

Troubleshooting


Problem

The Query Service metrics for a Cognos Analytics Dispatcher are showing all values as 0. 
 image of query service metrics values as 0

Symptom

While reports continue to run normally with no performance issue, the correct Query Service JVM metric values are not updated in Cognos Administration, and remain at 0. 

Cause

Any incorrect URI value in Cognos Configuration of the Dispatcher instance can cause this issue. 

Environment

Distributed server installation, with multiple dispatchers. 

Diagnosing The Problem

On the browser, go to IBM Cognos Portal

1. Click Manage
2. Go to Administration Console
3. Under Status tab, click System 
3. In Scorecard pan, select All Dispatchers. 
4. Click the affected Dispatcher URI
5. JVM values under Metrics pane on right side display values as 0. 

The values remain 0 even refreshing the page, deleting the cookies, cache, or trying in another browser. 

Resolving The Problem

For the affected dispatcher, open its Cognos Configuration, and under Environment, ensure all the URIs have the correct Fully Qualified Domain Name of the server. Make the changes, save, and restart the server.  

These values can also be cross-checked in the cogstartup.xml file for the affected dispatcher. This file is found under analytics\configuration\cogstartup.xml.


1. Stop the Cognos Dispatcher first.

2. Take a backup of the existing cogstartup.xml file.

3. Then, open the cogstartup.xml in any text editor and check the values of the following tags:

<crn:parameter name="hostName"> - This value is be the fully qualified domain name of the server. It can also be set to local host. Check the technote linked at the end of this page. 

<crn:parameter name="externalDispatcher"> Format is
<fqdn_server_name>:<port_number>/p2pd/servlet/dispatch
 
<crn:parameter name="internalDispatcher"> Format is
<fqdn_server_name>:<port_number>/p2pd/servlet/dispatch

4. Make necessary changes, save the file, and then start the services. 

Upon navigating to Cognos Administration Console now, the values are populating as expected. 

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3zAAC","label":"Administration"}],"ARM Case Number":"TS010625467","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.0;and future releases"}]

Document Information

Modified date:
13 October 2022

UID

ibm16825321