IBM Support

CSV output does not save with an extension

Troubleshooting


Problem

When running the report and generating CSV output, the file is saved without an extension.

Symptom

Generating CSV output opens a download dialog box with no option to select the file type to save as.

Cause

The RSVP.CSV.MIMETYPE parameter for ReportService and BatchReportService is not configured properly or has a typo.

Resolving The Problem

  1. Launch, IBM Cognos Administration.
  2. On the Status tab, click System.
  3. In the the Scorecard pane, click the arrow to view the Change view menu. Click Services, and then click All.
  4. Click the arrow next to ReportService to display the Actions menu, and then click Set properties.
  5. Click the Settings tab.
  6. Click Edit next to Advanced Settings.
  7. Select Override the settings acquired from the parent entry.
  8. In the Parameter column, enter: RSVP.CSV.MIMETYPE
  9. In the Value column, make sure the value is: applicaton/csv.
  10. Click OK twice.
  11. Redo steps 5 - 11 for the BatchReportService.

Document Location

Worldwide

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Document Information

Modified date:
23 September 2022

UID

ibm16823161