IBM Support

IBM i Access Client Solutions will not Launch from macOS Applications

Troubleshooting


Problem

When using the install_acs.js to install IBM i ACS on macOS, the application shows up in the Application directory, however, the application will not launch.

Symptom

IBM i ACS application not launching on macOS.

Cause

The Java JRE on macOS is primarily used for web browser base Java applications.  On macOS, IBM i ACS requires a Java JDK to be installed.  The document "Java Option for IBM i Access Client Solutions" document discusses Java distributions that can be used with IBM i ACS, though the Amazon Corretto Java 11 JDK would be recommended.

Environment

IBM i Access Client Solutions on macOS

Resolving The Problem

Download the JDK for MAC from the Java Web site to resolve.

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000CTpAAM","label":"IBM i Access-\u003EAccess Client Solutions"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.1.0;and future releases"}]

Document Information

Modified date:
24 October 2022

UID

nas8N1020849