IBM Support

My Cases search returns "No items to display"

Troubleshooting


Problem

Problem summary:
1) Enable "Show My Cases Search" on the Cases page in the solution
2) If you run the case solution and add cases on the Case Manager Client, then by using the search function, you can find your created cases .
3) However, the My Cases search returns no items as shown in the screen images.
image-20220916222904-1
image-20220916223223-2

Cause

The "My Cases" feature does not search the cases added by the user. My Cases searches for cases where
  • The user is a member of the Case team membership for the particular case.
  • Or where the user is assigned a Quick Task on the case.

Resolving The Problem

Refer to this reference for using 'My Cases' search.

1) Case team membership
To assign members to case teams, first add a button action to the Case details page or the Work Details page. Add the button action 'Manage Team' to the Case toolbar or the work item toolbar widget.

image-20220916224649-3

After you add the button, when you open a case or work item, and you click this action, you are presented a screen to assign members to a case. After you assign members to a case or work item, users who are not members cannot access the case or work item. Check this topic for the instruction of case teams.

https://www.ibm.com/docs/en/baw/22.x?topic=cases-managing-case-teams

2) User assigned to a Quick Task
In order to be able to create a Quick Task, make sure that the ability to create them is enabled on the Case Type. In Case Manager Builder, navigate to a Case Type in case solution, and make sure the enable quick task is checked.

image-20220916224831-4

In addition to enabling quick tasks on the Case Type, you need to make sure the 'To Do list' widget is on a page for the solution. For example, add the widget to the Case details or Work details page.

To create a quick task at run time, open the page with a to-do list widget, for example the Case details page. Type a quick task name in the to-do list widget and press return to create a quick task. Click the quick task name to open it and assign the task to a particular user, by using the user icon. Check these topics for the "quick tasks" introduction.

https://www.ibm.com/docs/en/baw/22.x?topic=view-quick-task-do-task
https://www.ibm.com/docs/en/baw/22.x?topic=case-adding-quick-tasks

Document Location

Worldwide

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Document Information

Modified date:
08 October 2022

UID

ibm16620975