IBM Support

Dashboard does not load after login 404 (Not Found) shown in browser developer console

Troubleshooting


Problem

Control Center Dashboard just keeps spinning and loading over and over again. Can not log in to the Web Console.
Can reach the launch page from the bottom of the log in panel and log in from the Classic Console.

Symptom

The Web Console will not log in just shows a spinning circle.

Cause

In the customers environment x-frames are being denied causing the 404 errors.
X-Frame-Options: DENY
In Control Center some panels are using a mixture of 10x and Angular so frames are being used which are set to SAMEORIGIN.
The customers environment their settings are not allowing those panels to be displayed.
If you specify DENY, not only will the browser attempt to load the page in a frame fail when loaded from other sites, attempts to do so will fail when loaded from the same site. On the other hand, if you specify SAMEORIGIN, you can still use the page in a frame as long as the site including it in a frame is the same as the one serving the page.

Diagnosing The Problem

From the browser use F12 to go into developer tools, and from the console and network tab you can see the 404 errors occurring.
A network trace will show the DENY being sent.
If your on 6.2.1.0 iFix08 or above you may also access the iFrame test page using the explicit url accordingly:
or 

Resolving The Problem

The best method is to change the environment from DENY to SAMEORIGIN.
The workaround is to use direct links to any of the Control Center Web Console pages that use frames.
Here are the direct links to avoid the frames which are being blocked.
Use http or https depending if your using secure connections or not.
Replace 58082 with the appropriate port, 58083 for default secure port.

http://Host-Name:58082/sccwebclient/manage#dashboard
http://Host-Name:58082/sccwebclient/manage#manage
http://Host-Name:58082/sccwebclient/manage#dashboard
http://Host-Name:58082/sccwebclient/manage#server
http://Host-Name:58082/sccwebclient/manage#servergroup
http://Host-Name:58082/sccwebclient/manage#simpleslc
http://Host-Name:58082/sccwebclient/manage#rule
http://Host-Name:58082/sccwebclient/manage#manage
http://Host-Name:58082/sccwebclient/manage#activealerts
http://Host-Name:58082/sccwebclient/manage#handledalerts
http://Host-Name:58082/sccwebclient/manage#completedfiletransfers
http://Host-Name:58082/sccwebclient/manage#completedprocesses
http://Host-Name:58082/sccwebclient/manage#queuedprocesses
http://Host-Name:58082/sccwebclient/manage#schedule
http://Host-Name:58082/sccwebclient/manage#manage
http://Host-Name:58082/sccwebclient/manage#files

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSJC3O","label":"IBM Sterling Control Center Monitor"},"ARM Category":[{"code":"a8m0z000000cwWHAAY","label":"WEB CONSOLE"}],"ARM Case Number":"TS010122309","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.2.1;and future releases"},{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSNG8A","label":"IBM Sterling Control Center Director"},"ARM Category":[{"code":"a8m0z000000cwWHAAY","label":"WEB CONSOLE"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.2.1;and future releases"}]

Document Information

Modified date:
22 December 2022

UID

ibm16608232