IBM Support

Users fail to sync from MAS to Manage due to index violation on email table

Troubleshooting


Problem

Issue 1: When one tries to add a user in MAS administration > Users, they are not able to add it. Even if the user's email address (Primary email) is unique, they still fail to create one.
Issue 2: When one updates a user's primary email address in MAS administration > Users, a secondary email address can be seen added in Manage automatically. This secondary email address is the last email address that got updated in MAS. Every time the primary email address is updated. Another entry of secondary email address can be seen in Manage. 

Symptom

Issue 1: One gets the following error while trying to add the user:
AIUCO1005E: Unable to create user. It exists.

Cause

Issue 1: This is caused due to the user's email address that is being used to create the record. If that email address is added as a secondary (optional) email address in a User record, which is existing in Manage, then a new user that uses that email address cannot be created. For example, if I have an existing user, say, Test1, which has a primary email address as abc@xyz.com and also a secondary email address as test2@xyz.com then a Test2 with a primary email address of test2@xyz.com cannot be created.

Diagnosing The Problem

Issue 1: Check whether the user, which is getting added is present in MAS administration. You can also check MAXUSER table in the database and in Manage > Security Users. If the user is not present, then find the email address in the email table. If found then you would see the corresponding PERSONID associated with that email address and also its ISPRIMARY column value, which would be 0.
Issue 2: Add a user with a primary email address in MAS. Then, update the email address and save the changes. Once it has got synced, go to Manage > Security > Users and look for the secondary email address under User Details > Personal > Primary email address > Show Manage/Values. You can also check the EMAIL table in the database for the secondary email address value (which not be present).

Resolving The Problem

Issue 1: One has to avoid that uses an optional email address of a user that is planned to be added in the future to a user that has already been added and exists in MAS administration as well as in Manage.
Issue 2: After the secondary email can be seen added in Manage and is not required, one can delete it from User Details > Personal > Primary email address > Show Manage/Values and save the changes. A defect has already been opened for this and is expected to be fixed in future MAS/Manage releases.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000F80hAAC","label":"Maximo Application Suite-\u003EMAS Applications-\u003EAdministration"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.7.0;8.8.0;8.9.0"}]

Document Information

Modified date:
09 March 2023

UID

ibm16607065