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Cognos stops automatically after just starting

Troubleshooting


Problem

After starting Cognos, minutes after it has started, Cognos stops working.

Cause

It's been identified that Cognos Bootstrap Service (CBS) is restarting the main Cognos application process. CBS is the initiating process and the first process that gets started. CBS will start Websphere Liberty Profile (WLP) which starts the Cognos application. CBS then continuously polls the Cognos application for a response. A response will only be sent once the Cognos application is fully started. If no response is detected, CBS will attempt to restart the main Cognos application Java process.
The reason why CBS is restarting Cognos is usually because it can't maintain a steady connection. It's been identified that there are several causes, all of which are environmental and not a cause with the application.

Diagnosing The Problem

The following logs are identified to showcase this:

cbs_run_WebSphereLiberty.log

CBSSocketCommand failed to create CAM handle:

 

After a certain number of failed attempts, CBS restarts Cognos:

Tue May 31 12:07:37 2022 WARN t[23dc] PingChildProcess process wlp hit ping failure limit, will restart, but first make sure it is really dead.

Tue May 31 12:07:37 2022 WARN t[23dc] PingChildProcess process wlp appears to still be alive, so stop it.

Tue May 31 12:08:27 2022 WARN t[23dc] PingChildProcess stopAction->execute() return status = 9648

Tue May 31 12:08:57 2022 WARN t[23dc] PingChildProcess restarting process wlp.

Resolving The Problem

  • Check to make sure the Dispatcher port is not used by any other applications
    • You can use Netstat to confirm
  • Check to see if you have any firewall/antivirus that could be blocking access from CBS to the Disptatcher
  • It's possible you're running into this security patch issue:

Document Location

Worldwide

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Document Information

Modified date:
19 July 2022

UID

ibm16605303