IBM Support

Cognos Administration Console rendering incorrectly without formatting

Troubleshooting


Problem

After Cognos Analytics is upgraded, the Cognos Administration Console renders incorrectly, without any formatting, and the links do not work. 
 

Symptom

This issue persists only when Cognos is accessed from Gateway URI. 

Accessing Cognos using the Dispatcher URI renders the Administration page correctly, without any issues. 

Cause

The IIS configuration for Cognos Analytics can get corrupted after upgrading. The issue can be within IIS or can be related to permissions to various files Cognos uses for formatting. 

Environment

Cognos Analytics Single or Distributed install, with a gateway server component installed. 

Resolving The Problem

There can be different approaches to resolve this issue.

It is recommended to run latest IIS Configuration script that comes with your Cognos Analytics installation. It can be found under ..\analytics\cgi-bin\templates\IIS\CA_IIS_Config.bat

If not using the script, this task can also be performed manually. Refer to the following URL:

https://www.ibm.com/docs/en/cognos-analytics/11.1.0?topic=services-configuring-iis-in-cognos-analytics
Here are the guidelines to follow to clear out existing Cognos configuration from Microsoft's IIS before starting a fresh manual IIS installation or running the script. Ensure all following steps are performed in the exact sequence:

I. Clear out existing Cognos configuration from IIS
 
  1. Open IIS
  2. Click Application Pools on left-side
  3. Select the Cognos 11 App Pool > right click and Stop it. You can also Stop from right-side under Actions menu. 
  4. Expand Sites > Default website > ibmcognos on left-side
  5. Select the ibmcognos -> sso application> right click and remove it
  6. Select the ibmcognos application > right click and remove it
  7. Click Application Pools, select the Cognos app pool, and delete it
  8. Close IIS

II. Then, in the file explorer, navigate to the Cognos gateway installation directory

Back up and delete the following web.config files:
  • cgi-bin\web.config
  • webcontent\web.config
  • webcontent\bi\web.config

Note: Do not delete 'Default website' in IIS. If 'Default website' is deleted, follow this technote to reinstate it before the IIS automation script is run: https://www.ibm.com/support/pages/node/6506439

III. Now, refer to the following URL to automate the configuration of Microsoft's Internet Information Services:

https://www.ibm.com/support/pages/automate-configuration-microsofts-internet-information-service-support-ibm-cognos-analytics



If not using the script, refer to the following URL to configure IIS for Cognos Analytics manually: 

https://www.ibm.com/docs/en/cognos-analytics/11.1.0?topic=services-configuring-iis-in-cognos-analytics
 

Note: If you have multiple web servers behind a load balancer, be sure to do this on ALL web servers.

IV. Once the script runs successfully, open IIS and then open the web browser. Ensure all cookies and cache are deleted. Access Cognos from Gateway URI and try accessing Cognos Administration Console. The page renders correctly.

 
Other known causes:
 
There can be instances where a customization skin is applied. Upgrading Cognos, rarely, can reset the access permissions for the user running Cognos, to the directory where the skins are stored. Normally the path is analytics/webcontent/skins/corporate. Ensure the users or group running Cognos has necessary permissions to this folder. 

In another scenario, upgrading from Cognos 10.x to 11.x, there's legacy "styles" set in Cognos 10 environment kept in the <install folder>\webcontent\skins. For broken images in legacy portions of the portal like Query Studio, and the Administration console, it is likely because a custom skin was set and affected these areas. To correct this, copy over the custom skin folder from 10.2.2 over to the same folder in Cognos 11 so that the references have something to complete the connection to. 

If this still does not resolve the issue, engage Cognos Support. 

Document Location

Worldwide

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Document Information

Modified date:
20 September 2022

UID

ibm16603019