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'TM1.ClientMessage Could not read message header.' is logged in tm1server.log

Troubleshooting


Problem

What causes this error in tm1server.log?
TM1.ClientMessage   Could not read message header.
 

Cause

This error message is safe to ignore.
Essentially the Planning Analytics server is receiving a message from client, and what is received is not handled or not valid. This message generally comes from progress or cancellation actions when the message is received it is because there might be too much activity at the time. A network blip could potentially cause this error message as well.

Resolving The Problem

If you would like to reduce the messages logged, Setting ProgressMessage=False reduces the number of requests going to the port. Please note that Setting ProgressMessage=False means users would not be able to cancel large views while they are loading up.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m3p000000LQtUAAW","label":"Planning Analytics"}],"ARM Case Number":"TS003609982","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
07 July 2022

UID

ibm16601927