IBM Support

Receiving "n.getServerTag(...) is undefined" error when accessing the new Routing Rules UI

Troubleshooting


Problem

When trying to open the Manage -> Configuration -> Routing Rules interface, the "n.getServerTag(...) is undefined" error is returned.

Cause

The error is caused by existing routing rules that point to a missing server group.

Resolving The Problem

Identify the missing server group and create it. Alternatively, access the classic routing rules UI in Cognos Administration. Go to Cognos Administration -> Configuration tab -> Dispatchers and Services. In the toolbar, select the specify routing rules button Specify routing rules icon. From there, remove the routing rule that points to the non-existent server group, or modify it to point to the correct server group.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3zAAC","label":"Administration"}],"ARM Case Number":"TS009827885","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
30 June 2022

UID

ibm16600023