Troubleshooting
Problem
For any nonsystem admin user trying to set up an Amazon S3 connection in Cognos Analytics following the document:
https://community.ibm.com/community/user/businessanalytics/blogs/antonio-marziano/2019/12/25/how-to-setup-cloud-object-storage-and-amazon-s3-bu
The user sees the error "cmNoWrite" or "Unknown Error" at step 12 or 13. This error comes after providing the Access Key and the Secret Key and then trying to click TEST or Create and Continue
https://community.ibm.com/community/user/businessanalytics/blogs/antonio-marziano/2019/12/25/how-to-setup-cloud-object-storage-and-amazon-s3-bu
The user sees the error "cmNoWrite" or "Unknown Error" at step 12 or 13. This error comes after providing the Access Key and the Secret Key and then trying to click TEST or Create and Continue
Symptom
The connection might test successfully but the users are not able to select the S3 bucket in the next step, prompting with the error at the top of the window "cmNoWrite" or "Unknown Error".
Cause
The most probable cause is the incorrect combinations of access permissions granted for the Save to Cloud and Manage Connections capabilities for this user and or group.
Diagnosing The Problem
The System Admin is able to create the Amazon S3 connection normally without any issues. This user and or group is unable to go past the screen after entering the Access Key and Secret Key. Refer to the screen capture posted at the beginning.
Resolving The Problem
The correct way to get past this error is to assign the Manage permission level for Save to Cloud and Manage Connections capability. The Manage Permissions level includes the follow access permissions:
- Execute
- Traverse
- Set Policy
Once assigned, have the users sign out and sign back in for the changes to take place.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
15 September 2022
UID
ibm16598389